Motion blur/artefact...Driving me mad!


I’ve got a problem with my map that seems to be motion blur or something similar but I can’t remedy it.

As you can see from my map as you go towards the water the orange material carries over on to the water, how do I stop this from happening?!Av7kWIyrlSmzgd8xdBC6AY9y1v5CTQ

Motion blur is unchecked in project settings so I’m tearing my hair out atm!

Would really appreciate some help!

That’s the result of Screen Space Reflections (SSR). The reflections can only ever reflect what is visible in the camera view. So, coming over a ledge like this with the orange and a really reflective surface behind it, the surface in the distance doesn’t know how far it is from this bright object it’s reflecting. This type of artifact is common in any games using SSR and not specific to UE4. You can disable them by adding a Post Process Volume that is unbound (checkbox in the details panel) and set the Screen Space Reflections Intensity to 0, or you can enable Planar Reflections to get real-time results that should remove the issue entirely.

Many Many Many Thanks, I massively appreciate that!

Tim, If I set the PPV screen space resolution to 0, my water disappears and becomes a flat uniform black texture in game and it’s the same if I add a planar reflection (Done by dragging out the component and placing just above the water and resizing it to the same dimensions of the water texture).

I’d really appreciate your advice on this its pretty perplexing to me!