Morphs not working after update to 4.17

We have updated from 4.16 to 4.17 and our pawn’s morphs stopped working.

Our current setup is a pawn with a base skeletal mesh component (character’s body) and many skeletal mesh components as children (character’s clothes). In order to update the pawn’s morphs, for each morph to edit, we iterate over all the skeletal mesh components, and if the current mesh has a given morph, we change the value. This was working perfectly until the update. Since then, only the morphs of the base component can be edited, not the children.

In 4.17, we noticed that morphs were not working neither in the skeletal mesh viewer for additional meshes (Check the following video captured from a new project where we have just imported two skeletal meshes with morphs)
Edit: Checked that it still doesn’t work in 4.18

Check Video here

Can someone reproduce this please? Is there some workaround?

Cheers,
Javier

I have exactly this problem too… Have someone a fix for this? My team is stucked :S

Best regards!

Jesús

They are definitely not working properly, did a simple sphere with bones in max and nothing

I also have the same problem. There is a slow engine problem compared to 4.14

same problem i m not able to get blink n lip sync animations of a iclone character into unreal engine 4.17 or to any earlier versions. Can anyone tell the way to get the morphs properly.

It still happend in 4.18 :expressionless: some fix or workaround for this? we are stucked…

Any news? It was not solved in 4.18

It may be a workaround for someone (not for me though), so I’ll post it here:
If you don’t need the additional skeletal mesh components to be children of the main mesh, you can put them all in the same hierarchy level and it will work ingame.
However the preview scene is still broken so we have to keep testing our morphs in older versions of the engine.
It would be very appreciated to get some answers from the staff about this.