Morph Targets not working on slave meshes in 4.9

This worked just fine in previous versions, but since 4.9 it simply does not work.

Our setup applies morph to master mesh (as set via SetMasterPoseComponent) and morphs (if they exist) automatically get propagated to all children.

We use this for body shaping, and for cloth overlap adjustments (eg hat and hair, or boots and pants).

4.9 release notes don’t mention that this was intended.

Could you please fix it? :slight_smile:

I also have this issue, I posted about this yesterday.

Here is a video proving the bug exists. It’s a real game killer.

Ohh thanks for that! Would you mind posting your link as ‘answer’ so I can accept it and we can close my copy of the question?

I think I have a fix for it, will post on your question

Better we keep both topics open until the bug is acknowledged. As for now I live on these bug reports until it’s fixed. I can’t move forward until this bug is fixed.

Fixed and ready for pull

This bug is fixed in UE 4.11 preview 8 :slight_smile: .

Regards, Cap :slight_smile:

This is actually not fixed. I and several team members have confirmed that it’s not only not fixed but actually worse then it was before. The main thread for this bug can be located here:

(There’s a video link near the bottom showing the current bug in 411p8.)

Hey Nightasy,

I’m now helping with the investigation on the other thread. We’ll have some updates there soon. Some of our test content previously didn’t cover all use cases, but I spent some time making new test content today. Thanks for your patience on this.


Just glad to hear it’s getting worked on. This issue creates some major limitations towards developing customizable character content.

Hi guys, with 4.11.0 out, I can confirm this is still not fixed; but the fix is quite simple. Link to pull request:

File: Engine/Source/Runtime/Engine/Private/Components/SkinnedMeshComponent.cpp, change line 1019 to read:

FAnimationRuntime::AppendActiveVertexAnims(SkeletalMesh, MasterSMC->MorphTargetCurves, ActiveVertexAnims);

First parameter should be mesh we’re adding animations to, not master mesh.

To reiterate the update in the other thread, I’ve entered two bugs from the info provided there: UE-28991 and UE-29003