Morph Target Normal

This is to report that the bug behavior I tried to test the morphing.

Dump2016_morphnormals90_3.fbx.txt will FBX exported in Ascii.

This data is then morphing a single square.
Target is moving only one vertex, is set to normal so as to be rotated 90 degrees.
Other vertices are fixed to lock the normal.

This file name to import in UE4 fix to [Dump2016_morphnormals90_3.fbx].

Then, also it will move normal that should have been locked.
Also deviated from the normal information of FBX morph targets.

For confirmation, use the FBX SDK, it was Dump the imported information.
It is the [dump_morphnormals90_3.txt].

You can see that also shifted import information.
UE4 also do not have the same phenomenon because the import is using the FBX SDK?

Also to Autodesk reported the same phenomenon, but the information I want, if that notice if Epic or someone else.

Thank you.

link text
link text

Information will postscript I did not have enough.

Code in UE4 also tried to read.
When the Morph Target is generated, and the normal of the Base is used, then
It had become stream so as to recalculate the normals.

In DCC tools, normals stored in Morph Target has not been used, also eject
could not.

Hi yuu,

Thank you for posting a bug report. I’m having trouble understanding exactly what you’re reporting. We’ve had a few morph normals issues. Does this look like your issue: Skin mesh + morph = broken normal - Character & Animation - Epic Developer Community Forums

I see from your profile that you’ve posted in the Japanese section of Answerhub. Could you type out your issue in Japanese and then we can have one of our Japanese support members translate?

Thank you for the link.
It seems to be certainly the same problem.

Then we understand also with respect to Section.
I’ll utilize a Japanese section.

Thank you.