Montage Branch Points not accessible from anim graph

I create a branch point in my montage but cant seem to access it from the animation graph.
From the comments on the link below it might be a 4.6 bug or a slight workflow change?

Link to Forum Post

Here are the steps I take with 4.6.0:

  • Create a new montage
  • Add a branch point to the montage
  • Check context menu in AnimBlueprint EventGraph … there is no “Add Montage Branch Point Event”

I save everything and close the Project and restart the editor. Go back to AnimBlueprint EventGraph and the context menu is now available and I can access my branch points.

I’ve tried Saving, Recompiling, opening/closing persona, refresh all nodes … nothing works short of restarting the project to get to the branch points. If you add a new branch point to the montage. It won’t show up in the context menu. So another editor restart is required.

I suppose its better than no branch point access at all :slight_smile:

Thanks for the answer :slight_smile:
I can confirm that restarting makes newly created branch points available on my end too.

Hi Drocks,

This issue has been reported for version 4.6.1 [UE-6982]. However, this issue has not been resolved and a new issue of not being able to create a branch point at all has taken it’s place in later builds of the engine (4.7 on). Waiting to hear back from the developers as to whether this is intentional and, if so, what is the new work flow? When I hear back, this post will be updated.

im using editor 4.7.0 and I cant create a new montage branch point either, i just don’t have that option when i right click, period. also my montage section doesn’t even have that branch slot like it does in the video any help would be greatly appreciated! heres a pic of what i see

sorry if im not supposed to post links, just desperate to solve this

This is a different issue than what has been addressed on this thread. This issue refers to not being able to access Created montage branch points in the animation graph. The issue you are describing is that you cannot create a new montage branch at all. Please submit a new AnswerHub post for that issue.

Hi Drocks,

The previous issue that was reported in [UE-5601] was very similar to yours but dealt with anim notifies and not montage branch points. I have created a separate report [UE-6982] to address the specific issue reported here. However, when testing in a future build of the engine, I’ve discovered that the issue IconoclasT has reported has taken the place of this issue altogether, which may or may not be intentional. To address this, I’ve submitted another report [UE-6983].

Due to the holidays, these issues will not be addressed until after January 5th. When they are resolved an update will be added to this post. Thanks for you feedback and bringing this to our attention.

Hi Fellas,

I just started on the 3rd person tutorial, using version 4.6.1… and I just wanted to let you know that I’ve gotten the same issue, the Add Montage Branching Point Event isn’t available until I restart the project.

Cheers and happy holidays !

Thanks for your feedback, but this has been answered. In case unclear, this issue has not been resolved and a new issue of not being able to create a branch point at all has taken it’s place in later builds of the engine. Waiting to hear back from the developers as to whether this is intentional and, if so, what is the new work flow?

Hey, sorry about that, I really didn’t write precisely enough …

I am able to create branch points just fine using 4.6.1. Only, I am not able to access the Created montage branch points in the animation graph . I need to restart the project. Just like the issue in 4.6.0.

because you had mentioned this —
This issue was reported [UE-5601] and was fixed with 4.6.1. If you continue to experience this issue after updating to 4.6.1 please reply to this post.

I thought I’d tell you guys I ran into the same issue after updating to 4.6.1.

I have revised my original comment to reflect the correct answer -I believe this led to the confusion. In short, it is still broken in 4.6.1. However in 4.7 preview, you can no longer make branch points at all. This has been reported but the developers are gone for the holiday. -Thanks for helping to clear the confusion of this thread.

Hey all,

Just to clarify, starting in 4.7, there is a new workflow for creating Branch Points in Montages. To do so, you actually start by creating a new Notify. Then you select that Notify, and in the Details panel, set its “Montage Tick Type” to “Branching Point”. These will then be available in the Animation Blueprint’s Event Graph (note that they are not intended to be used in the Anim Graph). The issue with not being able to select the Branch events seems to be resolved in 4.7.


I’m running 4.7 and cannot access the branching point (once created using the new Notifies method) inside my player character’s blueprint. The montage section doesn’t show up even after rebooting.

Hi TorQueMod,

Typically you access the the branching point in the character’s AnimBP (not the CharacterBP) as shown here:

If you are following a tutorial or steps where you must access the branching point in the CharacterBP, respond with more information on what you are trying to accomplish and I’ll research the issue further.

This is evidence that I should not work on projects late at night. I was accidentally looking in the default FirstPersonAnimBlueprint rather than in my custom anim blueprint :stuck_out_tongue: Not at all an issue, the events are showing up fine.