Monitor Editor Performance Bug

The Editor scales down texture resolution even when Monitor Editor Performance is unchecked. Auto scalability based on performance is still enabled somehow.

Hey Yaaks83,

What you are more than likely seeing with the texture resolution is actually an effect of Texture Streaming. What is happening is that your scene is consuming more memory than is allowed to be allocated, so certain textures begin to stream out of memory and render at a lower resolution to occupy less of the memory.

Texture streaming is based on a number of heuristics like Texture Group and Texture LOD bias etc. I would take a look at our Texture Streaming documentation to figure out where you memory is going and how to account for the low resolution textures.

Texture Streaming

With all of this said, if that does not resolve your issue can you provide me with a screenshot of your problem so I can visualize what you are experiencing?

If applicable, could you also provide me with some steps so I can reproduce the issue on my end?

Let me know if you have additional questions.

Thanks,

Andrew Hurley

I unchecked texture streaming, It worked! Thanks!. I had assumed that it would load the textures at max resolution, and not lower mip-levels because its exceeding the memory allocation limit.