Download

Modular Walls and strange light effect (tiling)

Hello guys I am fighting with this issue (or bug?) since a lot of time, but there is nothing I can do further to resolve the issue.
I am talking about the strange effect that is obtained if you build the wall using “piece” of that (modular).
I got some bad “tiling” problems (this should be the right terms).

I have already read other posts mentioning the problems as:

And it seems clear that Unreal can’t manage modular walls (I would also like to understand why), so the questions is:
How can I resolved this issue? Should I create “Rooms” externally ? What is the best approach to create rooms and something like that (without using BRUSH).

Many thanks for any suggestions or solutions.

Hi!

You are wrong: Unreal CAN handle modular walls but you will have to adjust your settings, as in every other application…
The why is: Unreal calculates light per mesh! If your settings are too low, you will experience shading differences!
The solution is: under your lightmass settings go with 0.1 Static Lighting Level Scale (1mm accuracy) and 0.6 with Indirect Lighting Smoothness and those lighting differences will disappear!
BUT you’ll experience blochy results or you’ll need to go higher with quality too!!
Also could be that the lightmap resolutions are extremely low by the look of the scene!! …and use minimum a Medium build for accurate results!

Hello Makigirl,
thanks so much for your response. I very appreciated it.
I have tried it and what I obtain is still tiling in shadow scene. Most probably I need to do a better “tuning” between the two values.
After all, most probably (and correct me if I am wrong) the brush geometry is the right way to do levels. I mean use brush instead of seperate meshes to do walls, cealings, floor and so on. I also read that the “modular” approach will increase the Draw calls in terms of performance.

I will try the two metods (brush vs modular static mesh for a while) in order to understand what is the best way for me ( for now the winner is brush).
If you have other suggestions, please let me know and thanks again :slight_smile:

Turn lightmap smoothness down/scale up as far as need be, increasing quality if you need to.