Download

Modular Synth stops working as soon as I set preset after updating to UE4.21.2

Hi, it used to work for me just fine on 4.20.3, but with 4.21.2 I’ve noticed the modular synth’s sound was gone from my game.
I played with it for a bit and discovered that as soon as I set a preset, even default one the sound is gone.
If I don’t apply any presets it’s back to working.
I’ve tried to play with different preset values thinking that maybe there is a new property was added that makes it silent by default but could not find any.

I’ve also noticed this in 4.21 release notes:

  • Bug Fix: Fixed various issues with Modular Synth presets.

So how do I use presets properly now?

Please help me out.

I assume you are setting the whole preset on the synth on every tick. That worked before, but we can’t do it like that anymore. Now we set the preset once, and then instead of doing the whole preset, we use individual bp nodes for each parameter on the synth, and set those on tick as needed, referencing the synth.
I liked the old way better, but maybe it’s because I was used to it. New way does let us do all the things as before, but with a little different approach.

Good guess! Live savior! Just to be more specific you need to set the preset once after you start the synth (not before). Thank you!