Download

Modular Pieces - Light Seams

Hi, I have had this problem for months and I don’t see the solution, the problem is that there are light seams bleeding through modular pieces. So after looking through countless online posts and tutorials I can’t find the solution, I created a little modular wall inside of 3ds max and UVW Unwrapped it and created a custom lightmap for it shown in the picture below where each UV Island has a minimum of a 4 pixel padding and all vertices are snapped to the grid. The level contains, a Sky Sphere, Sky Light, Light Source (Directional Light), and Atmospheric Fog. I have probably tried everything you can suggest including, generating lightmap UV’s with UE4 when I import it, Turning up the lightmap resolution, my lighting build quality is at production, modify the Light source by changing the smoothness etc, adding reflection captures, snapping the modules together in UE4, set the pivot point in 3ds max to 0,0,0, adding a lightmass importance volume and more. Adding a point light and setting the mobility to movable seems to do the job alright but seams still occur.** Please help as I cannot continue developing this game and thank you in advance.**

That kind of workflow is not a good idea

A few things–
First, the way the lighting works, it processes each mesh on a separate thread which means that indirect lighting will be slightly different on each part. When you construct a flat surface out of several meshes, then you’ll see the seams between them
The next issue is that it’s very bad for performance–each mesh is a draw call, so by making one object out of many you are creating a bunch of draw calls which will impact performance. The main reason for a modular workflow is to save memory, but since those meshes are extremely simple, you aren’t really saving much memory, it would be better to make a unique mesh that’s the exact size of the surface you want than to construct it out of separate pieces.
Another thing–don’t have surfaces around the edges of those meshes, they won’t be visible or contribute in any way, they can cause seams to appear as well so it’s better to just delete them. It does help with lighting for an interior if you actually have an exterior surface but you don’t want surfaces on top of each other.

Thank you, so if I wanted to create a building with an interior, there is an image attached below of something I want to create. How would I go about doing that? Without modular pieces. Or just creating a room.
b5da98cd5d048315663dd59905352013b53e93d5.jpeg

We used modular pieces the lay the rooms out and then merged them (developer tools->merge actors) to replace the pieces with single meshes. That way they got baked on the same thread and the problem disappeared. The attached screenshot shows a room that’s made of strips for straight pieces and corners and special pieces for doors and windows with holes in them. We just use these pieces to lay it out and merge.

2 Likes

*Right-click “Creating single static mesh from selected actors” and replacing the single ones could be a workaround *(it happened again)

“Force Volumetric Lightmap” in the object settings might help

The issue is that Lightmass processes each item individually, so the options that improve render speed like smoothing will only take those items into account which results in slight differences in the lighting between items. I’m not sure if that’s something that lightmap rendering systems all have to deal with or if it’s just that Lightmass hasn’t been designed well enough. Rendering lightmaps is different than rendering an image in a typical renderer.

best response\method I’ve came across…thank you!