Download

MODO users need your help: Y-Up rotation issues on FBX Import

So trying to import a set of meshes into UE4 and am unable to do that. As expected, that orientation is wrong. Used the UE4 preset for the FBX IO. Neither in MODO nor UE4 i was able to find an option that might be the reason it won’t import correctly.

Im a heavy Modo user :smiley:
I somehow dont have any problem with my rotations.
Can you elaborate a bit on your export workflow.
Do you use the game tools tab options? What fbx settings do you use? Which fbx exporter version?
Have you tried the non-UE4 presets in modo?
Since you used the UE4 presets, did you lso install the Modo plugin for UE4?

I’m also using Modo and have no issues importing into UE.
I use the UE fbx exporter in the gaming tools section from 10.x versions.

I can check if there is a option in the exporter to roate the mesh before the import into UE as my modo is setup to “Y” up and UE is “Z” up.
I dont use the modo plugin for UE as i do all shading in UE and not in modo.

Hi,

Do you by chance have your meshes grouped under a group locator? I remember that messed up rotation for me. :slight_smile:

WIthout group locator it worked as expected.

Then again, which version of Modo and UE4 do you use exactly?

Ok iam having a couple more issues with it than i thought. Using UE4.14 and Modo 10.2v1 (demo). Not using (or knowing about) the plugin.
What iam doing is blocking out a couple of assets. Not UVed yet. Just flying around on the screen. I Adjusted their Middle point (because as i learned from Warren Marshall, that’s the Pivot in UE4).
(See Attachment). I keep every seperate asset in a seperat Mesh item.
See attachments for Export and Import settings.
I realized, i had to click the scene name in the Items tab and that gave me the option change the Orientation. However Importing it through “Import into level” only makes the WHOLE SCENE orientate correctly, not the seperate meshes in it. It creates the whole scene as a static mesh with correct orientation (called FbxScene_) and all the seperate meshes in there with wrong orientation.
Iam a bit at a loss here. This can’t be correct.

Edit: The Modo Plugin really didn’t do anything.
35a6f6481ac24309633a01f2180313c551644da4.png9412d5fdce2cfe9838f1ae4b83c1ecb3db3a400e.png

Ok, you use the scene import. …have you tried exporting just one of your meshes and import it

  1. back into modo and see if something is bugged there

  2. import that one mesh normally into UE4, not using the scene import

?

Ok Taht worked better. I right clicked one layer picked “Export Selected Layer” (how many hidden ways of Exporting are there in Modo? Why not put them all in one Export menu point under file), using FBX2015 and at first using just the selected layer.
WORKED…yet the pivot is off.
Back to Export Selected and this time checking Export all Layers and Seperate Files. Importing all files and WORKED…just the pivot points are the origin of the whole scene and not the Center (hotkey 7) that i painstakingly defined for each mesh prior. Meaning the pivot is totally off for each mesh. Only way around this would be pushing the meshes by hand around the Origin Point but then: what would the Center function be for?

Is there maybe a more indepth and recent “From Modo to UE4” (just the export and import). From all the functions there are (Export as, Save as, Export selected which allows you to export all of them anyway) i have no clue what is the best to use.

Have you tried to import the meshes just per drag and drop. FBX → Content browser
Just to check that “FBX Scene import” isnt the culprit… :wink:

EDIT: Should have refreshed my browser sooner… Seems Rben beat me to it :stuck_out_tongue:

I will try tomorrow to just create a new Project and take the assets over. Maybe i did something to the Pivot or something.

Might be a problem working in modo.

In case you don’t know…

When working in polys the pivot will center on the polys. If you select by ITEM, then the pivot will be elsewhere.

You can fix by selecting item, move pivot to center of grid, select polys (select all of them), then move them to where you want.

Hmmm but isn’t the point of moving the center to where you want it, so that you don’t have zero out a whole scene to export it?
There is a way to zero the center point of the object without having to change it’s position…yet that doesn’t work with all of the layers at the same time, just for one at a time.

Here is the thing: IMporting it through File==>Import into Level breaks the orientation but the pivot is correctly where i placed the center in modo. Do I import it through Drag and Drop or theimport function in the content browser it’s orientation is correct but the Pivot is off.
(See Attachements) one time the door is flat on the ground but the Pivot is perfect and one time it’s orientation is correct but the Pivot is off.
Maybe i should absolutly wipe both apps and clean install them, to see if a modo without plugins / Scripts still has those issues.

2016-12-08 09_20_23-MyProject2 - Unreal Editor.png

Hey, can you share your LXF file of the mesh you’re trying to export?
There are so much things that could go wrong so it’s easier just to check original file

Sure thing, loading it up
does this work: https://1drv.ms/u/s!AgvMsKg7fDPQjSANvBet9u_9IrXw

I think something about my Modo install is broken. Created a new empty project, just created a block, moved the center to the object and export. Upon import the asset uses the Origin in Modo as Pivot not the center i adjusted.
Ok just for me to clear things up:

  1. If i don’t change Pivot or Center, the origin is my Pivot in UE4 right?
  2. The Pivot (HK 6) only changes things inside of Modo not in UE, right?
  3. The Center (HK 7) is what is supposed to work as Pivot in UE4?

Or am i totally wrong and actually have to zero out everything? This (1-3) was just what i gathered about the process from different sources.

Sorry for double post, but i think i found the information for this:
https://www.luxology.com/discussion/topic.aspx?f=83&t=124605
Seems like the center is bugged between UE4 and Modo 10. A new feature in UE4 (“Transform Vertex to Absolute”) seems to cause this.

Just tested it and…now the export selected Layers won’t write a file…fantastic telling me iam attempting this command on an incompatible scene…after it was working perfectly fine yesterday.

/Edit: ok cleansed my system of Modo with fire and reinstalled without plugins or anything and it works. One axis on the Pivot shows in the wrong direction but that is just a formalia. But it does what i wanted: import the right direction and use the center as pivot. So iam free to snap and work on my scene FINALLY. I will slowly but surely reintroduce Scripts carefully rechecking if things get broken.

Thanks so much everyone :slight_smile:

Maybe celebrated too early. Well Pivot works now but the meshes get imported with the wrong orientation again. Iam at a total loss here.
Maybe i should try importing it into a different 3d App. As i read FBX is always Y-Up so the problem would be with UE4…maybe…i don’t know. This is horrible frustrating that i have to waste my time on technical ****.
I reinstalled Modo clean, no PlugIns installed using the UE4 Preset for FBX. Rebuild my whole scene from ground. Used the Import function in UE4 and still it’s places Z up but doesn’t convert the meshes to Z-up.
I took a look into the FBX Import Options Reference (https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/ImportOptions/index.html)
And it says this:

However this option doesn’t do anything. I imported the files with on and off and it doesn’t change a single thing about this issue.

What if you use just the plain standard fbx export?

I will try that klater. Here is just what i have found out so far:
I think there is a bug in the FBX import. The “Convert Scene” clickbox seems to be not working.

  1. I imported the FBX straight from Modo in 2013 and 2015 standard (with standard for each in the FBX export, not UE4).
  2. I imported the Exports into 3dsmax and exported them with Z-Up and Y-Up (since Max has an a bit more advanced export tool that let’s me pick the settings for export on export and not in an unrelated menu).
  3. imported all of them into UE4 once with “convert scene” and once without (the modo exports and the Max converts)

All coming to the same conclusion, that a window element ends up flat on the ground.
Will do some more research into it, because i don’t understand why this is happening when a lot of people have no issues whatsoever

So I’ve played a little bit with your scene and scene itself seems quite normal, but yeah, I had some problems with importing a scene with multiple objects and saving proper pivot points

Transform Vertex to Absolute: Enabled
It “bakes” vertex transformations(Rotation and scale) per object and them splitting them afterwards, placing a “global” pivot point at 0,0,0 for all of them. This is why you’re getting correct orientation, but wrong pivot point

**Transform Vertex to Absolute: Disabled **
It disregards vertex transformations(Rotation and scale) for all objects and then splitting them using appropriate pivot points per object. This is what you’re looking for, but UE4 coord. system is Z-up and default MODO is Y-up. This disparity causes wrong orientation while preserving pivot points. I don’t know why it’s happening though - it could be a bug or intended behavior. Definitely worth an Answerhub question :slight_smile: I’ll post it on Monday when Epic people will be around

As for solution, the easiest one(Or the most straightforward) I found is to change Up axis in Modo from Y-up to Z-up. It’s in System->Preferences->Input/Units->Coordinate system. Also you have to compensate the change and reorient models in vertex/polygon mode to new Up-axis.

Edit: I can’t remember having such problems with single object fbx’s, hm.

First of all thanks so much for your help.
Okay that makes sense…kind of. Eventhough it seems like an odd behaviour considering other Z-Up apps (Max) have no problem this way.
It’s also odd that “convert scene” in the importer has no effect (which according to the documentation was build to effect misaligned Up Axis from apps like Blender).
So yeah would awesome if you could write about that. I guess changing Modo to Z-Up is a solution for now, just that i read a lot about it having issues AND it causing visual bugs with the Z-Axis being distorted in the viewport. But i guess for now i can work it out.

//Edit: eff me sideways. Still the orientation is messed up. Changed to Z-Up, rotated all my assets into place, adjusted the centers. Export…and assets are still in the wrong direction.
I think there is actually an issue in modo and iam starting to figure it out:

  1. There are 2 points at which you can change the Up-Axis:
    ==>Go System==>Preferences=Units
    ==>Select your lxo file in the Items view and you can change the Up Axis. (see Attachment).
    The problem is, that either does something different. The former changes your whole workplane orientation, so you need to rotate your assets to fit that.
    The later changes the direction in the file (and the FBX) but not the workplane. The problem is: Modo keeps the File Axis Orientation at Y-Up, no matter what i do and i guess that’s the issue (checked Saved every combination of Z+/y+, Z+/Z+, Y+/Z+, Y+/Y+ and at no point did the Importer in Max show a Z-Up File Orientation. I guess the FBX Import in Max and Ue4 basically says:
    if (fileorientation != systemorientation)

    Since it seems like the file orientation is never written to Z, it always rotates it no matter what.
    Here are the Asset files if you want to take a look at it:
    https://1drv.ms/u/s!AgvMsKg7fDPQjSE48Ov2YIzMOpw7

a1a1b9f9dbeb528ad499ec7276d9f9a813504377.png

Thought i can find something in the ASCII FBX files but nothing. Everything seems normal aside this:

When i save an FBX with Z as up, it saves the axis OriginalUpAxis", “int”, “Integer”, “”,-1 (if you use Y-Up in Modo it’s OriginalUpAxis", “int”, “Integer”, “”,1) and according to a blender document for Axis 0 = X, 1 = Y, 2 = Z (sign is just + or - Axis). Therefor -1 doesn’t exist. My Theorie was, that importer interprets -1 as Y and acts as if it’s build with +Y up (using unsigned). Changing the Axis to 2 for Z didn’t do anything.
I changed the 6 values that make the Up Axis for import.
From:

Which is the FBX standard +Y Up, and reimporting it into Modo showed exactly what i exported, to:

Which should mean something along the lines of Z Up, X Front. And it caused atleast Modo to import the FBX on it’s stomach. However UE4 was absolutly resistent to any changes no matter what. All imports came out the same way no matter what i did.