Modifying existing engine classes - doesn't work

Hello fellow developers!

Since Paper2D won’t be updated any time soon, I decided to update it myself. I need to extend the TileMap Editor with a few features. So I wanted to check out how things work, what are the right classes and so on. I thought it would be a good start to just change a simple string. I found the string which says “Early access preview” in the right bottom corner and changed it to “Johann was here”. I rebuild the solution and:

Nothing happened.

I restarted everything, searched some threads in here, watched the “Extending the editor with C++” video on YouTube, but nothing helped. Is it even possible to change the engine this way? Do I need to build the whole engine from fresh source code? What am I missing?

Hope that some one can help me.
Until then, greetings from Germany,


Hi guys,

I got it to work. I found out that the VS project was referring to the actual installation of the engine. I got rid of it, got the source code, compiled it manually and then tried again by changing the UE4 project, instead of the game project. It worked.

But no, the engine doesn’t need to be recompiled after every change. There is actually a way to HotReload plugins. It’s in the toolbar:

Window -> Developer Tools -> Modules

Then look for your module and click on “Recompile”.

I also changed my approach from “modifying the engine” to “create your own plugin”. I think it’s more sustained. It was a very instructive evening :slight_smile:
I hope that I could help someone who also experienced the same challenges.


By the way, I found it out by myself. Should’ve looked much earlier in the Developer Tools menu.

I click “recompile” and it recompiles very quickly.But nothing seems to have changed, although I deleted some lines from the source code.

What plugin are you trying to modify?