Modify nav mesh agent radius break agents


When I modify the minimum agent radius on recast nav mesh (default value is 35 I set it to 100), my agents can not move (there is no obstacle, just a large walkable area). Is it a known issue or are there some parameters to change ?

I just created a new project, generated nav mesh on default BSP and set a Simple Move To node on the default pawn asset. No custom asset was used, it seems to be an editor bug.

Thanks a lot.


It sounds to me like you’re setting your minimum agent radius too high. If you look at the tooltip, it says “radius of the smallest agent to traverse this navmesh”. If you look at the agent radius of the default ThirdPersonCharacter, it is set to 42, which is lower than required minimum, which you have set to 100. This is why your AI is unable to move using the Nav Mesh, because their agent radius is lower than what you have set as the minimum.

Let me know if you have any other questions regarding this issue.

Have a great day

Thanks for your quick answer, but my character capsule radius is greater than 100.
Also, I have increased this minimum radius because my AI stuck on corners (the capsule collide with corner), I just want to bake my nav mesh with enough space from wall and other obstacles.

Have a nice day

Interesting, would you mind providing repro steps or a simplified test project that we can use to reproduce this issue on our end? It seems to be working as expected in my test project, so it’s possible I’m missing a step somewhere.

This is a minimal blueprint project with one map with a simple pawn with a collision radius of 120. The level blueprint has just a Move To Actor to move pawn to a target point.


Repro Project

After some testing, scaling the Nav Mesh Bounds Volume up allowed it to cover the platform. The reason your character was not moving was because there was no nav mesh on the platform. Once I made this change, the pawn was moving as expected.

Ok, thanks again for your time.

Have a nice day

Yes, the nav mesh was not built, but I it works with min agent radius set to 35 but not 100. Sorry I believed I set the value to 100 before sending the project to you but it is still set to 35.

No problem, I didn’t check it before testing. I’ve reproduced the issue, and discovered that we have a bug report, UE-20920, in our system that is related to this issue. It is currently being investigated by our developers, but there is no timeline for when a fix will be released.

Have a great day

Is there any workaround? It sounds to me that this bug means you can’t change the navmesh agent radius at all, so all AI are going to end up being snagged on corners?

You can try setting it in the Project Settings->NavMesh instead of on the Recast Nav Mesh and see if that makes a difference.

Other than that, there are currently no known workarounds at this time.

That settings in Project Settings seems to have no effect. Even if I change it and delete all navmeshes and the Recast Nav Mesh, when I drop a new nav mesh bound volume it still has an agent radius of the default 35 and changing it still break pathfinding.

Other than giving that a shot, there haven’t been any devised workarounds at this time. If you are able to determine a way to work around this issue in the meantime, please share that workaround here for other users if possible.

Have a great day

Hi - I’m having the same issue here, did you find a workaround in the end?

I had the same problem, while changing some settings via Blueprint(RecastNavMesh-Default Object).
I added a “Supported Agent” on Project Settings and now I change these settings without problems.


After I found the solution, searching for “Supported Agents” I found this post:

Sorry about my English

1 Like

Thank you Aizenhar, this is excatly the solution I search…

I have found a solution where you can select which RecastNavMesh to use with any radius.
I explain in the answer of this question: Agent radius never works for my ai in 4.11 - AI - Unreal Engine Forums

This fixed my problem. does anybody know why this happened and why this fixed it? I can’t find the page in the docs that goes over the nav system in detail, just overview material.

Can’t believe it, it’s still not fixed and changing my navmesh radius still breaks it