Download

Modify Bounce Stop Threshold

Hi all!

I have a problem with my physics.
I have a basketball and i created a physics material for that, i also entered correct mass and some other basic physic settings.
The ball behave now like a basketball as expected.

But one problem i always have, with all balls and bounce in general, the bounce stop to early.
As you see in the attached image, at the end it immediately stop bouncing - Expected is a much lower threshold, as it is now it feels unrealistic.
It should bounce at least 4 times more at the end befor it stops simulating the bounce.

I have tested nearly all physic material settings, mass settings, damping settings, etc…
I can’t get rid of this problem.
Anyone have a suggestion?

I have the same issue :frowning:

You can try to reduce the Bounce Threshold Velocity from your Project Settings -> Physics -> Simulation.

That’s it 0lento! That’s exactly what I was looking for. The default seems to be 200, but reducing it to 100 improved it greatly while keeping simulation stability. Thanks a ton!