Model import from Blender is taking forever, how to improve model output -> settings?

Obviously i do something wrong, i just imported a model only with the meshes but it takes forever, Unreal is creating thumbnails and simultaneously updating shaders, for a lot of meshes. How can i export my model in a slim version with just the essentials? Thanks


Quick fix: Select all objects in Blender and then in Edit Mode use CTRL - J to merge all objects to a single object. Additionally i exported only “Selected parts” and in Unreal import settings unticked Animation.

-make sure to disable “import texture” and create material
-in blender → delete everything that you dont need (e.g meshes that you just used for animation reference), old animations,… :slight_smile: