Download

Mod works in test but not in SP or MP

Hi all, back again to try to get this Mod off the ground.

What I am trying to do with this mod is to change the crafting cost of each item. I have watched the video of how to add a new item to the game and have successfully added a number of items, which all work fine in a test map. You can see the new engram the the cost of crafting is what it should be.

However, once cooked and uploaded, I open a SP game select the mod. The game loads but the engrams are not there and the mod is not shown when you press ESC. So I thought, ok, I will try it on my MP server. I upload the mod to the server and added it into the server command line. This server is also running 19 other mod and mine is the first in the list. The second is a stack mod which works fine, but mine is still not showing any engrams. I also tried it with just my mod and had the same result.

These are the steps that I take to add new items to the game.

Modding steps for Casual Crafting Costs

  1.   Find Item and make a copy in mods folder and rename
    
  2.   Find engram and make a copy in mods folder and rename
    
  3.   Find icon and make a copy in mods folder and rename
    
  4.   Open Item change Description, Change Icon Location,  Change Blueprint Time to craft, Change Resource required
    
  5.   Open Engram, Change Engram Points, Change blueprint location
    
  6.   Open Icon change Brightness to 10
    
  7.   Save all files
    
  8.   Go to Primal Game data, Add to Master item list (at the end) and to point it to item, Duplicate engram in engram list and point it to engram
    
  9.   Save and move file to appropriate folder eg Weapons. Save
    
  10. Test
    

Also if I do it this way will it be a clean mod?

I am not sure why it is not working. The folder on my server does not show a folder structure that the mod has. Other mods that I am running have a folder structure in them. Could there be an issue with the way it is cooking there are warnings but it completes successfully and uploads fine.

Any advice would be greatly appreciated.

Don’t bother with the Master List, with other mods it is almost useless as there will most likely be a conflict - nullifying that ID. Additional Engram Blueprint Classes is where you should be adding the engrams, unless you want to replace the in-game engrams where you would use Remap Engrams(this will make the mod dirty - core-data change).

You do not mention the Level file nor the GameMode file. These must be set up and included else your mod is nothing. The Level file points to the primalgamedata file, telling the game where to find all the content(and tells the DevKit where to find things to cook), and the primalgamedata needs to point to your TestGameMode file.

-WM

Sorry for the delay have been a bit busy.

I will check out the Additional Engram Blueprint Classes and see if that helps. Have also been thinking of changing a few things and may have to make a clean and a dirt mod.

I have both of the files you mentioned as pre the video from Drake. I will have a look just to make sure they a set correctly.

Thanks for your help I will let you know how I go with it.

Hi, I am having the same issue as you above, appears to cook fine (although there are a lot of warning spam), but when I subscribe, download etc and then go to my ark mods folder, there are no assets at all, just the map, mod.info and modmeta.info, when I look in the devkit mods folder everything is there.
Were you able to fix? or is anyone able to shed some light on this issue? (what have I missed?)

Check the final entry.

Thanks for the response!

Ok so its half working now, the map, primalgamedata and testgamemode are all going into the steam mods folder, the custom dino color I added is working… but the additional folder I’ve made with a blueprint for a custom dye in it is not. Directory structure is there within the dev kit mods directory, but when downloading from steam they are not present within the ark mod directory… Any thoughts on why this is so?

Files must be linked in the PrimalGameData for the cooking process to include them.

Essentially what that means is, a file must be connected to the PrimalGameData in some form. A creature for example has is textures, materials, etc all attached/linked to itself, if that creature is linked to the PGD, then - by extension - the textures are linked to it as well so it cooks them.

Another example, Widget Blueprints(UI’s) are linked through the Create Widget node in graphs.

There must be a link somewhere for it to detect that file to cook. A quick and simple way to check references is the reference viewer, right click on any file and you can use that to see everything that it uses and that uses it by tweaking the search parameters.

I cannot remember, but do a quick search in the PrimalGameData for “dye” and see if there’s an additional array or something for them, otherwise I guess you could use the Extra Resources array that’s also there, if you do that however, there will be no way in-game other than the giveitem “blueprint’/…” command to obtain it. Otherwise, you need to implement a means of getting the the dye in-game. I think cooking pots make dyes or something don’t they?

-WM

Thanks for the info, yeah I’ve gotten the dye so it can be spawned in, didn’t notice there was a master dye list, was putting it in the master item list, so have moved it… I am assuming to be able to cook it in a regular cook pot it’ll make the mod dirty, unless I make a custom cook pot… for the moment I will allow it to only be spawned in and getting it craftable in game will be another project.

Thanks for the tip about the reference viewer, can now use that on similar items to see whats required.

It doesn’t make the mod dirty, it’s not a core-replacement, the additional structure engrams array is called additional for a reason. It’s there for people to add things to the vanilla structures, it’s just the Dev’s either haven’t implemented or found a way to dynamically alter a structures engram inventory dynamically or at runtime. I’m sure they will one day.

The main reason modders don’t use those arrays for vanilla items, is because it requires a structure to be rebuilt for it to update and use the mods items, then - coming back to the dynamic alteration of the inventory - when a mod is removed things can get screwy.

-WM