Download

Mod works in SP but not MP

I’ve created a mod that modifies supply crates using event graphs. When I run the mod in Single Player, everything works perfectly. As soon as I run it on a dedicated server, everything works except the node where the supply crates loot item set is swapped out. I’m guessing that this has something to do with authority or replication, but I’m not sure what needs to be done to correct the issue.

I have an Array of PrimalSupplyCrateItemSets that is passed to a GetArray with the index set by a RNG (It’s limited so that it always selects an index within the bounds of the array). The result is passed to a Set Item Sets Override node. Again, this works perfectly in single player, or if I host a non-dedicated server. It does not work if I run the mod on a dedicated server.

I’ve tried setting the Array to replicated, but that didn’t change the result.

Also, on another note, if I test this in the editor with 1 client, everything works. If I run it with the dedicated server box checked, the crates spawn and everything looks correct, but I can’t access the inventories.

Any help or insight would be appreciated.

Why on earth are you using graphs?

i would say the switch doesnt have authority - thats my guess. I have seen a lot of “works in single player but not multiplayer” issues in the past, and, the resolution was simple, just, dont remember what it was. I was a map designer, not a BP mod maker so i didnt run into this kind of thing.
The exact setup of how this should work, you got me on this one. I would PM someone whos done the drops mods in the past and see how it was resolved.

Because I don’t want to simply map the crates 1:1. I want to re-do the existing crates while also adding additional ones.

What file is the graph in? It sounds like your issue is the activation of the modified crates not replicating to the clients.

The graph is in my custom supply crate BP.

I created a BP that is a child of the SupplyCrateBaseBP. In my PGD, I re-mapped all of the supply crates with my custom crates.

You may be right about the activation. When I test in the editor with either 2 clients or as dedicated server, the crates spawn with the correct color and level requirement, but I cant access the inventory (when running as two clients, the host can access the inventory). I’ve taken a look at the graph on the parent and it calls “Set Container Active”. I added that in my graph, but it didn’t seem to change anything. I could be adding it or using it in the wrong context though.