Download

[MOD] Some servers do not see the mod's engrams in their engram list

Hello, I’m new to ARK Modding and I’ve been working on a mod called Compound Bow Plus:

Several server admins have complained that after adding my modification to their server they cannot see the engrams in the engram list. They can, however, spawn the items and blueprints in without problems (suggesting to me that they have the files in the right place). Their spawned in items fail to persist after a server restart though (suggesting to me that the mod isn’t being loaded by their game when their server starts). I’ve asked what other mods the server admins are running - the only mod that is in common is the Glass Metal Walls mod and I have been able to run my mod alongside that mod without issues on other servers.

My mod adds three engrams (Tranq Metal Arrow, Drain Metal Arrow and Harpoon Metal Arrow). I’ve specified that these three engrams should be loaded in PrimalGameData_BP_CompoundBowPlus and my settings look like this (otherwise, besides Mod Name/Description that file is completely unmodified from the GenericMod example):

Could someone please point me in the right direction? What have I missed or am I doing wrong that is causing the engrams not to show for some server admins who are running my mod?

For exact details of what the server admins have told me, please have a quick scroll through this discussion on the mod workshop page:

Downloaded your mod and looked at the files present. It seems like you are missing the map file and game mode. In the screenshot you are showing the world settings of the testmap, make sure you set the “Primal Game Data Override” in your mods level file aswell as the testmaps settings are only relevant for testing in the editor. You also want to set the “Default Game Mode” in the primalgamedata to your mods testgame mode.

Edit: I also just noticed that your primalgamedata is a child of the generic mod primalgamedata. You should copy the generic mod files not child them. The issue with a child here is that the generic mod files don’t exist in the base game, only in the editor.

Thanks for the reply Mezzow. I didn’t realize that the map file needed to be included. I will rewatch some mod tutorials to see if I can find instructions on how to do what you have described. If you know of any particularly good tutorials on this and you could share them with me I would really appreciate it. In the mean time I will also take a closer look at the GenericMod example and how it is done there.

Oh my goodness - I can’t believe I missed this. Mezzow your comments are super helpful - forget my request for a tutorial, I think I’ve figured it out just from your comment. I will report back with how I progress :slight_smile:

Mezzow I have followed your advice - a few screenshots are attached. Any chance you (or others reading this) could take a quick look and let me know if it looks right to you?

I’ve added two new files in my /Mods/CompoundBowPlus/ folder called CompoundBowPlusMap (copied over the TestMap.ark) and GameMode_CompoundBowPlus (copied over from /Mods/GenericMod/ and left unchanged).

In the map I have specified the Primal Game Data Override as PrimalGameData_BP_CompoundBowPlus (you can see that on the right hand side of the screenshot). When I play the CompoundBowPlusMap the engrams show in the engram list correctly.

In PrimalGameData_BP_CompoundBowPlus I have set the Default Game Mode to GameMode_CompoundBowPlus. I’ve also made this an independent blueprint - it is no longer a child of anything.

Is this setup properly? Is there anything missing? Can I expect this to work properly when I next upload it to Steam?

Sorry for all the questions. Your help is appreciated, thank you in advance :slight_smile:

Hey,

dont use the testmap as your level. You want it to be emtpy. Create a copy of the GenericMod level or make a new empty level.
You want your PrimalGameData_BP_CompoundBowPlus to be child of the CoreBlueprints/PrimalGameData_BP, so changes from base game updates will carry over.
You want your GameMode_CompoundBowPlus to be a child of the CoreBlueprints/TestGameMode.
The settings themself look fine.

The easiest way to get this setup with the right parents from the getgo is to just copy the three files from GenericMod into your Mod folder, rename them, load the level, set your Primal Game Data Override to your mods PrimalGameData, in your PrimalGameData set the Default Game Mode to your mods GameMode, save everything and you are done :smiley:

Thanks so much for your help. I implemented these changes and I’ve rolled out an update. Now I just wait patiently for server admins to let me know if it made a difference, or not!

Hmmm… so first user to give feedback has told me that the engrams are still not showing for them on their server. I’ve compared v0.3 and v0.31 (implementing the changes suggested in this thread) and there are two new files - a CompoundBowPlus.umap file (the blank map) and a GameMode_CompoundBowPlus.uasset file (the Game Mode file).

What else could be causing this issue? Any help is greatly appreciated.

Does anyone have any other suggestions for what might be causing this issue? I’ve had a few people look over my mod now and those settings seem to be correctly set. What else could be preventing the engrams from showing in the engram menu correctly?

Just an update - I finally seem to have gotten to the bottom of this. It seems there were problems with the files in my /Mods/GenericMod/ that I was using as the basis for some of these files. I deleted all of these files in the root directory of my mod and started again. I made the Level, GameMode BP, GameState BP and PrimalGameData BP from scratch following the instructions at this link:

And hey presto, now it seems to be working for my users (as of v0.32).

Thanks for the replies Mezzow - it really helped. I also have to say a huge thanks to TyoAtrosa for helping me test my mod properly (and confirm the fix worked) along with jslay who took time to go through all my mod settings with me.

Awesome. Sorry I wasn’t able to be more help myself. Mezzo is the man!! A guy you should always trust and rely on when he provides information.

Did you originally child the files instead of copying them? A few people seem to be doing this lately for some unknown reason so I’m curious to understand where people get the idea from. I fear it to be due to a lack of formal basis for people to reference. Hopefully the Liaison coming soon will spearhead the restructuring of the forums to clear things up, else I’ll have to pester Jat to get things done.

-WM

WoefulMacabre - to be honest I don’t remember whether I originally childed or copied them but I’m pretty sure I copied them. I was following along with a YouTube tutorial and he was adding a slower arrow to the game, or something like that. In the tutorial though he never exported it to the Steam Workshop and from what I understand this problem won’t show in the Dev Kit if you’re using a test map with the GameMode and PrimalGameData overridden - so maybe the tutorial is a contributing factor if this has affected more than just me?