Mod plugin doesn't load

I followed the modding tutorial to try adding a single DataAsset. Unfortunately it doesn’t work, my content isn’t found at load (using the asset registry) and the mod isn’t mentioned in the logs.

  • The .pak file is created correctly and i copied it to the /Content/Paks/ folder in the built game.
  • I tried removing the pak option to ensure the mod asset was getting cooked.

The plugin seems fine. It just won’t load in the game. No mention of the plugin is done anywhere in the log.

Is there any way to check that a specific plugin was loaded ? Can I get a list of loaded plugins ?

Hello Gwenn,

I followed the tutorial you linked and almost everything worked fine for me. I did run into an issue where the floor in the map that was loaded was missing, although everything else was present, along with the modified shooting. I believe that’s due to not including Engine Content, while this floor is from Engine Content.

Would it be possible for you to add a level, even if it’s blank, to your plugin and then try the process you’re using? Once you launch the game, try opening the map using the console as shown in the tutorial and see if that will at least work for you so we can try to narrow down what’s occurring.

As far as checking to see if a specific plugin is loaded, I’m not sure but it doesn’t seem like it would be possible. In the modding process, we’re only taking the .pak file itself and adding the content to the project manually.

Hi Matthew, thanks for the hint. I can confirm that a new level doesn’t load either (not in the autocompletion for “open”, “open” doesn’t work).

Here are some shots from the profile launcher for the mod :

Do I really just need to copy the pak file and no other plugin config / ini file etc ?

Ah, that may be it. In the first picture, that drop down should be set to your particular project instead of Any Project. Yes, all I copied was the .pak file. I renamed it as mentioned in the tutorial as it comes out with the same name as the base game’s .pak file, but that’s all I edited. Doesn’t seem to matter what the new name is either.

I just tried changing that setting on both the main release profile, and the plugin profile. Didn’t change a thing. Isn’t that setting just intended to select the current project ?

I also can’t get the example mod to work. I’m using UE 4.13.0, from a source build. All options appear to be as in the modding page.

The tutorial has a weird thing though : the “Cooked Maps” section is empty. Should I tick something ? For the full release, or the plugin ? Both ?

I have a map listed in my Cooked Maps section but it’s just the FirstPersonExample map and doesn’t show the ModExampleMap. Are you sure you’re including everything else such as cooking being set to “By the Book”, packaging set to “Package & Store Locally”, and your “Release version this is based on” matches the “Name of the new release to create”? Also ensure that your plugin matches the “Name of the DLC Build” exactly.

I’ve tripled check but I can’t get it to work. I’m now testing on the demo project.

Here is the profile for my release launch :

Here is the plugin profile :

Just to be clear, I only add the plugin to the plugins folder after building the full game, and before building the plugin. Are you sure this works ?

That’s not the workflow I’ve tried as it isn’t how the tutorial went about it. I tried this on my end and once I added the plugin back in and tried to cook the mod, I received an error about the .dll being incompatible so it’s never even able to finish cooking when I try to add the plugin afterwards. Can you try following the workflow put forward by the tutorial and see if that works for you before we try deviating from it?

This has to be a mistake. How is building the plugin as part of the game release considered modding ?

Obviously the plugin needs to be added after the release has been generated, or this doesn’t make any sense. Are we really talking about modding here - modifying the game on a user’s computer, based on a previous release ?

Still doesn’t work.

Keep in mind that when it comes to UE4 modding, if the intention is to have your users create mods for your game, you’ll need to give them an editor version of your game. A good example of this is Ark: Survival Evolved. As seen in the Epic Games Launcher, you would need to download the Ark Dev Kit to mod the game. You add your mod content, cook the game first, then cook your mod, and then distribute that mod. There are general questions/answers about UE4 modding here:

As far as getting this working, just to have a completely controlled case down, what happens if you open the “PackagedSampleGame” folder from the tutorial’s assets, run “ModSampleGame.exe” and then type “open ModExampleMap” into the console?

The packaged version does work. I can’t reproduce it, even by following the tutorial step by step. Can you confirm that the above screenshots are fine (profile settings) ? Did you try this on 4.13.0 ?

I’m still trying to understand the modding limitations. My game is open-source, doesn’t depend on a custom engine, so people could just download the sources and build it. I don’t understand why they would have to do a release themselves, isn’t the asset registry enough to generate a mod ?

The only difference that I see in your settings is that I never checked the FirstPersonExampleMap. Although that shouldn’t matter, it may be worth checking. All of my testing of this has been in 4.13.

As far as the limitations of modding goes, as mentioned by the tutorial, this entire process is still in its early stages and will likely change in the future. They don’t have to exactly “do a release”, if I’m understand what you mean by that, they just have to cook the base to generate that content and then cook the mod.

Well, it doesn’t seem to be working with those settings. I guess I’ll let modders try themselves.

I apologize for not seeing it before but I just noticed that you mentioned that you’re using a source build; Have you tried using a binary build to see if you get the same results? It’s possible that the process may be different when using source.

We haven’t heard from you in a while, Gwenn. Are you still experiencing this issue? If so, was what I suggested in my previous comment of any help? In the meantime, I’ll be marking this issue as resolved for tracking purposes.