Mod not working after cooking


So I made a really simple testmod that adds a few items. It works in the devkit. I watched tutorials to circumvent the most common mistakes. One of them being the world settings that need to override “primal game data” and “gamemode”. Then I cook the mod and set the output directory to the mod folder of ARK. I do not understand the “maps” setting during cooking so I just gave it the same name as my mod level file. Then when I start ARK I can see my mod and I enable it. But after it’s loaded I don’t see any items. I made sure all the settings are saved. What am I forgetting?

Thanks in advance.

This could be a simple issue with the PrimalGameData. I recommend deleting the one you have and creating a child of PrimalGameData, which you can search for in the PrimalEarth folder. You should adjust the name and description of the mod in your PrimalGameData_Child and add your engrams, then load this mod by itself. If the PrimalGameData fails to load, pressing escape will show no information for the server name and description.

I took BASE_PrimalGameData(not sure which primalgamedata you mean) which had added settings for setting “App IDItems” compared to the generic primalgamedata I used before. I added name and description in it and added my items. I also redid the level file and the testgame file. Set the proper overrides in the world settings. Saved everything. Tested it in the devkit, cooked it and ran the game. Same result, the mod shows up but no custom items. If I press escape I don’t see any mod description. Im out of idea’s.

Go to the PrimalEarth folder and search for PrimalGameData. Drag this to your Mod’s folder and create a child of it. Editing anything outside of you’re mod’s folder won’t take affect in your mod, as the only thing that gets cooked and uploaded is what’s inside of your mod’s folder.

I did that. There are four files. BASE_PrimalGameData_BP, Base_PrimalGameData_BP_Child, CORE_PrimalGameData and PrimalGameData_BP. I used the first file I mentioned and it’s in my mod folder. I did noticed my Level file still has a reference to this BASE_PrimalGameData_BP file in the reference viewer but I can’t find any setting that actually contains that reference. This reference points to my mod folder so something strange must have happened when I renamed that file (I will check again to see exactly what happens when I copy and rename that later today). I did find the “PrimalGameData” reference option in a dropdown but the content browser can’t navigate to it. The file does not seem to exist when I search in windows explorer either.

edit: By creating a child you mean copy right?

No, I mean a child. The option to create a child is there when you drag and drop. The reference to the Level is located in the World Settings when you double click the Level and open it up.

Nothing is working man. Did everything you said so far.

You should be able to do this:

Create a new mod folder
Drag in a PrimalGameData_Child
Drag in a Level
Altar the name/description in the Child
Cook and run it
Press escape and see your new name/description

Ok so this happened:

I created a new mod folder.
I copied BASE_PrimalGameData_Child to that folder.
I copied GenericMod level to that folder
I renamed both files.
In the PrimalGameData I added a mod name and description.
In de level file I referenced my PrimalGameData file and removed the force load map name.
I cooked it and ran ARK.

The previews mod I made “RolePlayMod” which is enabled by default when I start a new single player, now has no name in the mod selection screen. I also don’t see the TestMod I made. It seemed as though there is a conflict between the two mods. So I deleted my previews mod from the ARK mod folder. Relauched ARK with the same exact result.

Don’t rename PrimalGameData. It only works if the name contains PrimalGameData.

the name still contains PrimalGameData I only replaced the Child part of it.

If the devkit crashes like for instance when renaming a file could that cause things to become corrupted or break references in some way that it might cause it to malfunction? I happens every now and then and im starting to think that might be my problem although it didn’t crash on my last attempt.

Small improvement. The name of the mod that shows up in the mod selection screen in ARK is actually the name that is set under the “upload” section of the cooking window. Not the name that is set in the PrimalGameData. It’s still not loading my mod in game though.

Even if I use the GenericMod, give it a name and cook it. It will replace my previews test mod in ARK and also the generic mod won’t load.
never had a problem with my mod following this, if you didnt skip anything, you shouldnt either.

That is strange because i followed the exact same tutorial 2 times from scratch.

Ok I discovered something new that might help pinpoint the problem. When I have multiple mods and all are cooked it always only shows the last cooked mod in the ARK mod list eventhough all mods are present in the mod folder. Any idea’s on this?

Attempt: 27986576

I reparented the PrimalGameData to the BASE_PrimalGameData. I entered “ALL” the fields in the cooking screen including image(Small) change notes etc. Cooking… still no luck. Mod shows up but still doesnt load.

Attempt: 27986577

Uploading to steam. I cleared my output directory as that seemed needed to enable the upload button after cooking. I uploaded my mod to steam. No problems. After about 1 hour my mod does not show in steam. Not in Most Recent or in my own Workshop Items. Do I have to wait longer? Even if it shows up I don’t think it’ll work but im running out of options.

edit: the one I uploaded is Public and is called GenericTestMod.


I got it to work. The first time I uploaded to steam it turns out my password was wrong but the screen disappeared so fast that it didn’t show and I thought it was done without errors. So I subscribe to my mod and play ark. I press esc and voila there is my mod name and description. I still don’t have a clue why I have to upload it to get it to work properly in my game but at least I got it to work now. pfff I think that was attempt 27986578 :stuck_out_tongue:

Of course you have to cook and upload your mod to steam for it to update or work in the live game. You must go through this process for every update you do.