Download

Mod not loading

So I unsuccessfully tried to create my first mod following the steps in the tutorial. Renamed the GenericMod files to TestMod, PrimalGameData_BP_Test and TestGameMode_Test. Pointed the files to each other like the video showed.

Cooked it (without making ANY changes), downloaded it in steam. Go to use it in local play. Goes to loading screen, loading bar at the bottom says “Loading PrimaGameData_BP” (note: mine is named PrimalGateData_BP_Test). Loads for a couple seconds, flickers back to the main menu. I don’t have the slightest idea how I could be doing anything wrong. My game files, the dev kit, and the unreal engine binaries/plugins are all up to date (all pulled today).

Help! I just wanted to change tamed dino health scaling :frowning:

Fixed, got it to load by using the coreblueprint rather than the genericmod one. Now to figure out why changing the Amount Max Gained Per Level Up Value Tamed (health) values has absolutely no effect >.>

I have a question if you can. I can’t get mine to cook anything at all. What do you mean by coreblueprint? Sorry, I’m not dumb, I swear. Just REALLY new to this whole UE4 thing. lol

I think he means the coreblueprint from the corebuleprints folder not the one under mods/generic folder

Oh interesting… I’ve been using Generic Mod blueprints as a baseline… I wonder if that’s causing my inability to get a v188 mod to run on a dedi server

If you can’t get any of your files to cook, try renaming(prefix,suffix,etc) your files something unique to that mod. Seems like shouldn’t have to do this, but it was the only way I got my files to cook and show up in the modtools output folder.

(ignore - issue related to referencing mod name instead of map name in start line)

Thanks everyone. I’m going to try again to initiate my modding ideas lol. What I was doing was “create a blueprint based on this” (for instance, I wanted to change a Phiomia) and rename it say (mygeneric_bp_phiomia. Not actually that but you get the idea). but nothing would cook at all. Even when I created something from scratch. Going to try to redownload the files in Github and see if maybe it was something with that.

I’m too stubborn to give up. I am using the blueprints in the Coreblueprint folder
I even tried modifying the default Phiomia itself to no avail.
Oh, I even redirected everything to point to my Phiomia…still nothing lol.

i got the exact same problem when i trying it in the local but when i coock it i get alot of warnings but i trying to validate it now and see if it works

The warnings that appear when cooking are to be expected! Do not worry, it’s VERY normal to see that happen. The warnings have nothing to do with it not running on a dedicated server.

  • Sinari

mine worked after i deleted the old game data and game mode and copyed them instead of making them as a child

Steam will not overwrite the Github update… Not sure why you think that since the Binaries and Plugins are not noticed by the steam validation. As for the MOD, in a lot of cases MODs will not load when there is already a save file in place on the server, you will need to start a new game, this is not always the case tho. For example if you remap spawners they will spawn in new Dinos over time with the changes, while if you remap dino for MOD dino on an already established server with previous saves before the MOD those new dinos will never load in the map.

Actually it had nothing to do with any of that… my issue was using the mod name instead of the map name in the start line. I erased my post so it doesn’t confuse people - might want to erase your one above as well!

Closing thread as issue has been resolved it appears! Glad you got it fixed :slight_smile: