Download

Mod cooking not working/confusing

So I spent hours creating a mod, everything works fine in the dev kit the changes are showing with no problems, but when I get to “cook” the mod the process tells me it was “successful” so I upload the mod and all that is “cooked” and uploaded is just three files not the whole mod -.-

Why is that thing telling me “Successful” when is NOT “cooking” all the assets in the mod folder!?

It should let me know what it was not “cooked” and why.

Not gonna go through twenty hundred lines of text in the logs trying to read confusing warnings and errors.

Is there a way to cook a mod through command line or with some other option?

After reviewing the files in explore I see that the mod is not actually being cooked:
B00000002.png

So how can I cook the mod folder and upload my mod using SteamCMD?

How would you know whether it’s being cooked or not?

You have to upload it to steam after cooking in order to access it anyway. How would you have any idea where it’s storing the cooked files or what it is or isn’t doing with them??

The DevKit’s output folder is essentially what the clients use, except SteamCMD compresses the files behind a proprietary archive which is a pain in the ***, anyway, checking there will tell you what is and isn’t being cooked.

OP, ignore cook warnings, they’re irrelevant, errors are the issue(if any arise).

I’m going to be pretty patronising here, but have you made sure that your level file points to your PrimalGameData, the PrimalGameData points to your GameMode and that you’ve linked all of your files correctly.

I can’t exactly tell what creature you’ve modified, but you’ll either need to remap the creature(NPC) in the PrimalGameData or add it as a new one, which requires the dino entry, and probably be added to a spawner(which then gets remapped as yours is custom) - this will make the mod dirty however.

Don’t take my word for anything however, I’ve not messed with creatures yet, but a mod I’m working on when I have free time is a map, TC, creature replacement and game mode so I’ve started learning what I can about each aspect.

If you haven’t already, make sure you’ve checked the adding new dino variants thread. Here.

-WM

I was able to figure it out what I was doing wrong, had to double-click my level file (the orange one) and from there link my primal game data and my game mode files in the world settings, also when I was cooking the mod I was changing the name of the map but it should be the name of my level file.

I wish the cooking tool would check the references inside the folder you’re cooking and tell you if the files inside the folder are not linked together.