MobileContentScaleFactor not working properly with Mobile HDR off

There seems to be something wrong with changing resolution while Mobile HDR is off.

This is the correct behavior with Mobile HDR on:


Mobile HDR on; uses MobileContentScaleFactor 1; Resolution 1280x720 on 1920x1080 display

Mobile HDR on; uses MobileContentScaleFactor 0; Resolution 1920x1080 on 1920x1080 display

And here is the problem. When I turn Mobile HDR off, the MobileContentScaleFactor doesn’t work properly anymore and the shown image gets out of bounds.


Mobile HDR off; uses MobileContentScaleFactor 1; Resolution 1280x720 on 1920x1080 display

Mobile HDR off; uses MobileContentScaleFactor 0; Resolution 1920x1080 on 1920x1080 display

Hi Alphisto,

Do you encounter this issue only when dealing with stereo view or does this occur in a normal display as well. I ran a quick test on our mobile device and was unable to reproduce your issue.

Could you provide a list of steps that lead you to this problem.

Thanks,

Ed

Hi. I went through your wiki on setting up your project to run in VR on android. https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/QuickStart/index.html
I also use Screen Position to drive different images into left and right eye from a single material.
Could you please try this with a simple VR project for mobile? If it works for you I will do my own stripped of big data and upload it here.

What device are you using? I would like to run my tests on the same device so that I am more likely to see the issue.

Also here is how I plan to run the test.

  • Create a blank mobile project (HDR enabled)
  • Create a device profile that changes the MobileContentScaleFactor
  • Add print string so resolution change is apparent
  • Launch to device
  • Turn Moble HDR off
  • Launch again
  • See if there are resolution issues.

If my test doesn’t address the issue let me know and I can adjust the steps.

Hi, the important thing is not to use HD or QHD, since that is MCSF 1 and MCSF 2. I have been running the failing project on a FHD Nexus X mobile. Thanks

Hey Alphisto, I haven’t forgotten about this issue, there are very high priority issues that have come up but I will get back to this issue as soon as I am able.

[Edit] I ran a test on a different device and didn’t reproduce the issue. I’m going to get my hands on a Nexus and continue testing. I’ll update you with my findings.

Hey Alphisto,

I got in contact with one of our mobile developers, at the moment we think it may be an issue with buffer resolution. Could you provide a log from the device?

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

Ed Burgess

Hi, I could provide the log but I don’t really know how. Is this something I turn on in Unreal?

Hi, I could provide the log but I don’t really know how. Is this something I turn on in Unreal?

(1.) Make sure that the TADP (Android SDK) is installed on your PC. Browse to the following location and run the ‘monitor’ batch file
C:\NVPACK\android-sdk-windows\tools (see screenshot labeled monitor.jpg)

(2.) The Android Debug Monitor window will appear. Important functions are labeled in the picture and explained below.(See screenshot labeled monitor2labels.jpg)

(3.) The connected device and its Android OS version will appear under the ‘Name’ area. Click on the device name to make sure that logs are being generated.

(4.) Screenshots can be taken with the screenshot button and they will be saved to your PC

(5.) Under Saved Filters, select ‘UE4’ to display logs from the game only or select ‘All messages’ to display device logs as well.

  • If you do not have a saved filter for UE4, click the green plus symbol under “Saved Filters” to create a new one.

  • Under “Filter Name”, type UE4.

  • Under the field “by Log Tag”, type in “UE4|debug”.

(6.) The logs can be cleared by clicking the icon beside the disk icon

(7.) In order to save the session’s logs:

  • Click ‘Edit’ in the top menu bar and select ‘Select All’. The logs should appear highlighted.
  • Click the disk icon and a window will pop up asking to name the logs and where to save them. Only highlighted log entries will be saved so make sure to highlight them all first.