Mixamo to TPP Character


I am trying to get my custom character to work with the Movement Animset Pro. I want to rig through Mixamo, but I was just wondering how well this would work for me. Has anyone else tried doing this? Does the Mixamo UE4 export work for these animations?

If you do it via Mixamo, You should just be able to import your mesh over the Epic Skeleton and it’ll work just fine. That’s what I did with my free Mixamo autorig and it works like a charm :slight_smile:

Did you use the optional 3 joint fingers?

I just left everything at default and it works smoothly :slight_smile:

Okay, it’s working for me, but the rotation and the fingers are off a little. I’m sure I can get it with a little messing around.

“Retargeting Adjustments” on this page may address the issue your facing:

Hi - I am trying to do this and for the most part it works but trying to import the animation from Miximo it’s rotated 90 degrees, so my character walks and runs with the Hero tpp animations just fine but the gangam dance animation he does on his back LOL

got any ideas?

Are you using the ue4 movement set or unity version? i had trouble with my mixamo rig?

Forgive me if i misunderstood, itz 4am here! Did you apply the animations on the mixamo site/fuse tp combine? also did you export a@ fbx for ue4?

When i tried unity movement set in ue4 editor my mixamo character would faceplant when moving and slid about… even after retargetting. I ditched unity in favour for ue4, I’d hate to waste my assets which cost afair bit.


ahh it’s possible I wasn’t paying attention when I downloaded the animation - I ended up applying 90 degree rotation when importing and all worked out OK


I am having some trouble when I follow this tutorial

in order to import a mixamo character as a substitute for the default character in the 3rd person example map.

Although I can replace the skeletal mesh and the animation blueprint generated class with the mixamo character’s mesh and class, the playable character moves without animations when I play. I mean that the character remains in the default T-like posture while he moves but he can rotate and also jump but without animations.

Also I noticed that when I create a new animation blueprint, the animgraph tab doesn’t appear. This happens also when I make a copy of the existing animation blueprint of the third person template character. The new animation blueprint doesn’t have an animation graph tab.

Any ideas? What am I doing wrong?

Thanks in advance.

Sounds like you haven’t applied the animation blueprint to the character. The animation blueprint is what will give you the animations on the character when you swap the mesh. So if you’re doing this change in the blueprint itself, add the “Set Animation Blueprint” node (if I recall correctly). If you’re editing the character directly, look for the animation blueprint section and change it there.

Thanks for your reply.

Which blueprint do I have to edit? Where do I add the “Set Animation Blueprint” node?

I followed this tutorial now:[theme_id]=200088027

but I cant find the defaults tab of the animation blueprint of the default blue 3rd person character. When I press the class defaults button in that blueprint I dont get the “animation blueprint generated class” menu. Is this menu the same with the class option in the class settings tab?

bump, anyone?