Download

Mixamo Character Texture/Material Problem?

I’ve managed to import a character and animation into ue4 but it looks like this:
MixamoChar.jpg
How do you fix this there seem to be materials for body, brows, eyes and mouth but I’m not sure how to correct these?

I finally figured this out after weeks and weeks of being completely stumped. The issue is that on the main body texture there are RBG and a sneaky Alpha! His face needs to be applied as a separate material that essentially crosses out the weird face you are seeing.

  • Create a new material or duplicate your existing body and give it a new name like… Aj_Face
  • Click on the long attributes node (base color, specular, opacity etc…etc…) and under the details set this material to TRANSPARENT
  • Under your BASE COLOR drag the top pin to the Base Color as you normally would
  • Still under BASE COLOR drag the Alpha pin to the EMISSIVE pin
  • Assign your normal as usual, Your Specular and Roughness map should be the same texture just plugged into different pins.

I am doing this all from memory, and I may be forgetting a step but let me know if this worked as I scoured the internet for almost 3 weeks trying to find a solution.

How can I set it to transparent? I wasnt able to find anythings like this. And also what do you mean with “Under your BASECOLOR drag the Alpha pin to the Base Color” and " drag the alpha pin to emissive pin"?

hey there. can you make it clear with the steps you did please?
where to make the material to transparent

The way I fixed this error was to go into the material node map for each of the mat files (bodymat, topmat, etc.), click on the main texture node, then go to the details tab and select opaque in the blend mode dropdown. Hope that helps.

Thanks a bunch I couldn’t figure it out either. These steps worked.^^

I happened to encounter the same situation as you did. Here is how I solved in UE4 4.20:
1> Open the Boy01_Mouth_MAT1 in Material Editor
2> Click the Result Node , change “Blend Mode” to “Masked” ,as shown in the attached picture.
3> Hook Alpha of Texture onto “Opacity Mask”
Then apply all the same steps above to other Material except Body_MAT

Good Luck.

thank you :))))

It took me awhile to figure out that you had to click on the “Result Node” in order to see the details column with Material Domain & Blend Mode & Shading Model info. I had a whole lot of trouble with Mixamo characters and hair being nearly invisible. This posting really helped. Many thanks.

For anyone else with a problem with Mixamo Adam’s hair and beard, the settings are, Material Domain: Surface, Blend Mode: Masked, Shading Model: Hair.