Mixamo animations root issue

Few months ago i used mixamo to get some animations for ue mannequin and it worked all fine in 2 clicks. Now i tryed to do exact the same thing and im getting a weird result in ue , all animations look like theres no root motion and they run in place though i didnt set “in place” in mixamo moreover there was no such checkbox. I tryed all kinds of exporting / importing settings and nothing works out . I even tryed to reimport the same animation i already have and it refused to work also .

Heres how it looks like bandicam 2019 01 31 16 18 51 559 - YouTube

The same animation which was imported earlier bandicam 2019 01 31 16 19 11 330 Trim - YouTube

Im keep googling for 2 days already and cant get what i do wrong.
Ty for any help!

Same issue here :frowning:
have you tried this : How to properly import Mixamo animations? - Character & Animation - Unreal Engine Forums ?

i looked through decades of forum posts trying to make this work, so yes i tryed it. For now i gave up with animations, working on other stuff

Looks like the animation is meant to have root motion based on your videos. So, you want to make sure you have “root motion” enabled and “force root lock” disabled on your animation asset.

I have highlighted where the force root lock setting is in the animation asset.

I have struggled with bringing Mixamo into UE4 in the past but lately I have perfected a workflow that brings them into UE4 every time, without fail. So if you can’t get your existing animations to come in nice I recommend you go back onto Mixamo and re-download your animations. Then, use Blender and [this guy’s Mixamo to UE4 add-on][2] (I use the batch mode and don’t change a single setting from default).

I have also attached an image of the add-on running in blender with the key ui highlighted.

1 Like

Hello, Terribilis studio has published a free tool to import mixamo animations with the UE4 skeleton it’s automatic easy and fast! (Root Motion work perfectly)

Did it work for you with mixamo converter?

Would have been great if someone would just tell us what causes this in the first place


I should mention that the reason there are issue’s with Mixamo Animations such as this, is because Mixamo characters had no Root bones, so the animations aren’t True root motion animations. You would need to transfer root motion from the Pelvis to the root on your characters to make them proper root motion animations.

Here’s a video on how to do it in iClone but you should be able to do this on anything with a Curve Editor, possibly even Unreal since the new animation system in UE5 has a Curve Editor.