Mixamo Animations Retargeting problem, wrong rotation root motion

Hi, I created a char in Fuse, imported to UE4, and downloaded some animations like dual combo in and I made work in root motion, the character is going forward with the combo.

But now is the problem, when I retarget the animation from Fuse character to UE4 mannequin, the root dont move anymore in the new retargeted character, so the animation still works, but the animation dont move forward anymore, it just stay like IN PLACE animation.

I already tried to get the .fbx from mixamo and direct import with the UE4 skeleton, the root moves, but when I click on Enable Root Motion, the mannequin flip like that (same thing on new mannequin and old):

So i tried 2 different ways to get the animation from mixamo to another character without success. So if somebody helps me I will be grateful

Export the Mixamo character as FBX Unreal file (check when queue for download), then import with “T0 as Ref” the character and use the default Mannequin. The character then should work with Unreal animations. However, Mixamo animations are a bit off…and root motion is not working because Unreal root is on the ground, Mixamo between the legs. But when you export Mixamo with root motions as FBX Unreal, the Mixamo characters root motion should work, just not working with Unreal’s root motion system. Thus, don’t tick root motion inside Unreal for this specific animations. They are already root motions anyway. How you incooperate preexisting RM into your controller is another question, possibly through vector tracking.

First, thank you for your patience!

I did the steps you said, but the animation from mixamo is a combo that you go forward so these are my steps:

1 - I chose the slash combo animation of Sword and Shield from Mixamo

2 - Downloaded Queue the animation with the Unreal 4 FBX checkec with no skin

3 - Imported my fuse Character to UE4 again, now with the skeleton of UE4 Manequin to test if the bones are the problem.
4 - Imported the FBX animation to the UE4 Skeleton|, and surprise, it works both on root motion and normal motion on Fuse Mesh!


5 - Now I switched only the mesh in Persona to UE4 Manequin MESH, and go backs to flip.


Conclusion, 99% sure that is not the different bone and is mesh problem, or something on the animation FBX that match this root rotation only with my Fuse Character Mesh.

You have any idea what would be?

Don’t switch. I guess the Mixamo Character has a different pivot setup when it switches, but on imported UE4 corrects this for the Mixamo asset, but does not account for it when you switch to the UE4 Mannequin. Thus, import the animation extra for the UE4 ThirdPerson Character, you’ll have 2 different sword and shield animations, both imported. Not entirely sure, it might also be that you have to restart the editor. Btw i use 4.10.4 edition, there might be also some changes which may apply. But good that you got it now working for the new character. But basically root motion setting from Mixamo do not work when set in UE4, because of the different location of the root bone. This may be factored in when you import something from Mixamo, but does not effect UE4. When I use root motion on characters not from UE4, not from Mixamo, they loose grounding, during AI navigation, because of the root bone issue.

I wish there would be 1 standard for poses and bones which could be established, or more options for retargeting and importing. Currently retargeting of Mixamo animations screws up the UE4 arms…

I got it! But the main problem is that I dont want to use the fuse character haha, I have another main character but the same issue with the ue4 manequin happens. I will continue my research and update here!

The issue from the twisted arms I solved using the Skeleton transition instead animation, only the root and pelvis is set on animation scale and everything works fine (and I’m picky with ugly animations), only the forward movement animations is my problem, If I retarget I loss the forward movement, If I import directly from FBX and activate root motion the char flips, mixamo need to get a little better I think!

You could try to import the character, accounting for the flipping (i.e. Roll 90, Pitch 90). Also check the reference pose and make sure to import with “Use T0As Re Pose” ticked. Will try your suggestion with the anim scale.

everything on Skeleton, root and pelvis on animation scale

Can I ask a big favor please? If you have the last unreal 4.9.2 can you create a blank project and open the manequin animations and check the enable root motion please?

I think is the engine problem now lol

I don’t have 4.9.2