Mixamo Animation issue

Im rigging and animating my characters in Mixamo.

The run and the walk seems to have a rubberband reaction where the character will walk forward and then eventally reset a bit back and start again.

how have others fixed this issue?

thats because when you get the animations from the Mixamo website you have to select walk in place or you will not have adequate walking animations.

heh, I never noticed that. thanks for pointing out the obvious…

And the main reason is because Mixamo’s exporter is done for 4.5 UE skeleton and there are no plan for future updates.


silly question… does anyone know if there is a planned stopping date on the rigging and animations on the mixamo site?

If you’re talking about everything currently being free and when will it end, last time I heard they didn’t know themselves, they said it will probably last well into 2016 but no promises. I don’t have a proof link though, can’t remember where I read this.

Hmm, did you ensure that you ticked in place? I noticed there is a little bug with the ticking of in place for the animations, so press it a few times or press something else then go back to it to ensure its ticked… I think by the sounds of what you are saying, this is your problem.

That’s because those are root motion animations. If you enable root motion on animation clip and then disable it on blendspace/animinstance level, that should work.

ive enabled the root motion on the animation clip and the walk/run looks silly (hence this thread)

how would u disable it in the blendspace/animinstance level without that affecting the animation clip itse

In animation blueprint editor, in bottom left corner, in “editor preview” window there’s a dropbox called “root motion mode”. Try setting it to “Ignore root motion”. That will disable ALL root motion, though. Alternatively you could use “root motion from montages only”.

See screenshots here:

To check if root motion is enabled, you need to check individual clips you’re using. Double click on each. If character walks in place, then either there is no root motion in the clip, or it is enabled.