Download

Missing UE4Game binary

I’m running 4.10.4 with no additional plugins on Windows 7 x64. I downloaded the “Unreal Match 3” demo project from the marketplace and tried to package it to Android (ETC1), but it fails with the following error:
Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game <Platform> <Configuration>

I have followed all the steps for installing the Android SDK in the Android development guide.
I have no additional plugins in UE4.

In the output log I can see that the failure happens upon trying to stage the package:


MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: Execution of commandlet took:  12.20 seconds
MainFrameActions: Packaging (Android (ETC1)): CommandUtils.Run: Run: Took 15.790005s to run UE4Editor-Cmd.exe, ExitCode=0
MainFrameActions: Packaging (Android (ETC1)): Project.Cook: ********** COOK COMMAND COMPLETED **********
MainFrameActions: Packaging (Android (ETC1)): Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
MainFrameActions: Packaging (Android (ETC1)): BuildCommand.Execute: ERROR: BUILD FAILED
MainFrameActions: Packaging (Android (ETC1)): Program.Main: ERROR: AutomationTool terminated with exception:
MainFrameActions: Packaging (Android (ETC1)): Program.Main: ERROR: Exception in AutomationScripts.Automation: Stage Failed. Missing receipt 'UnrealMatch3-Android-Shipping.target.xml'. Check that this target has been built.
MainFrameActions: Packaging (Android (ETC1)): Stacktrace:    at Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
MainFrameActions: Packaging (Android (ETC1)):    at Project.CopyBuildToStagingDirectory(ProjectParams Params)
MainFrameActions: Packaging (Android (ETC1)):    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Android (ETC1)):    at BuildCommand.Execute()
MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Automation.Process(String] CommandLine)
MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)
MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Program.Main()
MainFrameActions: Packaging (Android (ETC1)): ProcessManager.KillAll: Trying to kill 0 spawned processes.
MainFrameActions: Packaging (Android (ETC1)): Program.Main: AutomationTool exiting with ExitCode=Error_MissingExecutable
MainFrameActions: Packaging (Android (ETC1)): Domain_ProcessExit
MainFrameActions: Packaging (Android (ETC1)): copying UAT log files...
MainFrameActions: Packaging (Android (ETC1)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
MainFrameActions: Packaging (Android (ETC1)): BUILD FAILED
PackagingResults:Error: Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game &lt;Platform&gt; &lt;Configuration&gt;

I’ve tried changing the project settings to package for Development, Shipping, Full Rebuild, but they all end with the same error.

Can anyone shed light on why this is happening?

I’m having the same problem for days… Couldn’t solve it yet… I assume that you tried to add code to the project?

https://answers.unrealengine.com/questions/209021/missing-ue4game-binary-failed-to-package-for-win64.html

same problem by me found the fastest and simplest solution. in your epic games launcher right click on the preferd engine -> options -> uncheck android-> confirm. This will delete it. Then the same again and check android for installing it again. like a charm! no worries anymore!

I facing this problem too.
Iam copy project folder to my some "archive versions" folder just to be sure if I make some bad changes I always can return to my previos version of my game. So solving is a replace binary folder (ProjectFolder/Binaries) from the version of project that Ive copied earlier.

Seems like some binary file was crashed because of some of one plug that I`am trying on

What worked for me was choosing shipping in the build configuration settings.

1 Like

four yearlater i am still having the same problem on the official downloaded version (4.21) epic is a joke. A bad joke.

4.24 the same

Hello folks!

Did you tried fully reinstalling Android SDK/NDK and the Engine and also cleaning the build and intermediates folders?

Cheers!

Just solved this for my case. Hope that this will be of use to someone struggling. Here are the steps that I took. I was getting a message saying Missing UE4 binary…

In the binaries folder there was no Android folder created.

When this error happens it seems to be because the builder has failed to create the .target file and therefore it is complaining that this is missing.

I could play the project fine in emulation mode.

Steps to resolve:

  • I created an empty first person project and it all built ok and ran on the device so I knew it had to be something project specific but there were no errors to do with this in the log.

  • Changed the deployment mode to shipping.

  • Deleted the binaries folder - not solved

  • Removed all plug-ins I added - not solved

  • Tried post above i.e. Went to epic launcher and tried unticking all other build options and then updating and then only ticking Android - Not solved

  • Copied the project to a different drive so I had a version to experiment with

  • Deleted the intermediates and saved folders (had unreal closed down and in windows explorer deleted the whole folders).

  • I built and it complained of some mapping errors. I had some static mesh components that I was using as dummies. I changed these to scene components.

  • When this rebuilt it now gave some errors on the log to do with some C++ code I had in. Two things:

  • I had a try catch inside a function and this gave an error because the project doesn’t allow exception handling - don’t know if this is a problem just for Android and the windows build just ignores it but it stopped the build.

  • In my CustomLevelScript editor I had added the #pragma once directive and an include, I didn’t need those so I took those out.

  • Now it builds and I can see it on the device. It’s like to view the errors in the build you need to delete the intermediates.

Try Changing The Build Configuration To Development