Missing SharedPCH.Engine.ShadowErrors.h.pch

I just installed UE and I am trying to learn how to use it. So I have created a simple Puzzle game (C++), for which I gave the name “puzzle”, but when I try to create the Project, there is an error message stating that the SharedPCH.Engine.ShadowErrors.h.pch file is missing on Puzzle\Intermediate\Build\Win64\PuzzleEditor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.pch

In the error message there was na option to compile it with Visual Studio. I clicked, Visual Studio opened, but in the end it gave me the same compile error.
I checked the directory and this file is not there. Well, actually there is a file SharedPCH.Engine.ShadowErrors.h.pch.response but I do not know if it is the same file.
I tried to change some configuration options on the Solution Explorer but that made things worse…

Since this is a sample program I was expecting it to run without problem, but I have been unable to do it. I am not sure if this is just a configuration issue but I could not find anything that could help me with that.

Does anybody have any hint of what this problem might be? Thanks

1 Like

I had this problem too, very similar. First I fixed mostly with this


Problem solved, imo no full reinstall needed, just modify VS installation, and keep only the latest Win10 SDK (uncheck old version, apparently UE4 uses it for pch creation somehow, but the latest for everything else, but I’m not a pro, just guessing)


Did that and also installed from here:

This two things leave me create the project but then I got the same issue that you had.
Then I found this:

Apparently I coudnt compile the project when I created a new one because I had it on:
C:/Users/Ignacio Olazábal/Documents/Unreal Projects/
That á was the problem
So I created it on:
And the errors disappear. I still don’t understand how I could not create a project with a folder with an special character. But is what it is.

Hope that some of this odyssey helps you :smiley:


Thanks for the reply, I believe that this was also my problem. I somehow manage to solve it too, some time ago by trying different path and folder names. There was also a special charactere in the path I was using. In fact I ended up using a much shorter path and no special character and it did work :slight_smile:

In my case the solution was much simpler: the path for the project contained a special character (“é” in my case). It was sufficient with using one without any special characters.

Ran into this issue a couple of times so far both in private and at work.
So far the solution almost always was to simply remove special characters from the entire filepath.
If no other solutions help I’d also suggest trying to remove spaces from the filepath.

Best regards,


Thanks a lot)