Missing rig bake to control rig drop down

Can anyone help, when trying to bake to control rig there is no rig to select in the drop down, I have tested with another project and it’s working in that but my current project it’s missing on the body but not for the face. Tried importing another MH but believe the problem is with the project not the MH.
Thanks

2 Likes

I found it, I had Filter Asset By Skeleton selected which then didn’t give me any options, unselecting this shows the control rigs to select again.

8 Likes

But that will show you control rigs that are not suited to that Skeleton, did it work???

1 Like

@thehemsley Thank you, man!

This didn’t work for me, was this the only solution?

Yes it work, it was probably because I had edited the body and face outside of unreal and then reimported them.

Did you ever get yours to work? I am having the same issue as you as the fix above in this thread did not work for me either

I’m having the same issue. It shows some control rigs from the project but not the new one I created inside Unreal.

I was able to figure it out for me, if you made your own control rig you need to make sure it has a ‘backwards solve’ node structure in order to bake to the control rig.

3 Likes

The above reply by Cheeky fixed it for me, thank you so much. Here’s the documentation for forwards and backwards solve to assist others.

To make a backwards solve I’d recommend copy/pasting your forward solve node tree; select each new node, and use the details panel to change the target from ‘Control’ to ‘Bone’/‘Bone’ to ‘Control’. Next to that option, each node must be changed from the Forwards-solve bone to its control rig counterpart, or vice-versa. Make sure to double-check every single new node to ensure you re-enabled them properly for backwards solve. It’s a cumbersome, but very simple task; check the first 1:30 of this tutorial for help with the above.

A new issue however: I’m now able to bake the control rig in sequencer, but when I do the animation just T-poses and the keyframes don’t register. Edit: Issue fixed! Just some simple sequencer settings; this video helped immensely.

1 Like