Missing "Project" Modules

Hey, I’ve recently started to work on a project and downloaded it from github. When I opened my Project.uproject I got the message


When I rebuild it crashes and gives me the message


I’ve downloaded the source as well from github but I can’t seem to generate project files correctly!

I am on a Mac OX Yosemite. Could someone help me out?

You need to provide some more information, do you get any specific error on project generation?

Directory ‘/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs’ not found.

Seems you missing something in development tools, you sure you got XCode installed properly?

Yes I did!! Here is the log:

Setting up Mono
Generating data for project indexing… 0%Compiling with non-standard Xcode (xcode-select): /Library/Developer/CommandLineTools/
Triggered an exception while looking for SDK directory in Xcode.app
System.IO.DirectoryNotFoundException: Directory ‘/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs’ not found.
at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in :0
at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path) [0x00000] in :0
at UnrealBuildTool.AppleToolChain.SelectSDK (System.String BaseSDKDir, System.String OSPrefix, System.String& PlatformSDKVersion, Boolean bVerbose) [0x00000] in :0
ERROR: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs


I had the same problem today. I discovered that within the Xcode preferences you need to set the command line tools location to be the current version of Xcode you are using.

You can do this by going to Xcode preferences → Locations → Click the drop down next to Command Line Tools and then your build should work (well mine did at least).

hey this worked for me! thanks!

On later versions of Xcode, the SDKs are located under /Applications/Xcode.app, not command line tools. You can get around this with the following command from terminal:
ln -s /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

Worked for me too! Thanks for this, been searching for awhile.