Missing level map

When i open my project i just cant see two of my level maps in the content browser, they are missing! But i open my content folder and their still there. I think ue project is not detecting it up, is there a way that i can refresh my content browser? i tried to clone the project but still the same.

I have the same problem, I can see the .umap file in the content folder but ue4 content browser cant seem to detect it. The reason it happened for me is the my PC shut down while ue4 was running and it might cause some problem saving the map data. Unfortunately i did not find a fix or how to recover the .umap :frowning:

I have the same problem. You know how fix?
Cya.

1 Like

This might not help Dash07, but hopefully it helps anyone else who runs across this. I had the same issue and was able to “fix” it by deleting the .umap file from \Documents\Unreal Projects[projectname]\Content* and replacing it with the most recent copy found in \Documents\Unreal Projects[projectname]\Saved\Backup.

When I renamed the backup file to match the name of my level, UE4 immediately recognized it, and it showed up in my Content Browser. This copy works without issue.

5 Likes

Hi drummerof13

I just wanted to say thank you very very much for your information …
I lost about four hours of work on a new level i made and with your answer i was able to recover it …
Thank you so much !!!

1 Like

Developer440, have you tried the steps I posted below?

using4.14 in mac as its the only version that works,but my map created in PC, doesn’t show up under ’ open level’

I had to chmod - x the file as it was showing up as a exec in tacos directory, hoping that would fix it.

Any ideas?

thx

Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xfffffff8

UE4Game-Win32-Shipping.exe
UE4Game-Win32-Shipping.exe
UE4Game-Win32-Shipping.exe
KERNEL32.DLL
ntdll.dll
ntdll.dll
ntdll.dll

Ok, I had this problem too. Last night my project was perfectly fine. this morning, I turn on the computer, load up editor, and discover that the level file I’m working on is missing in editor browser, but not missing in it’s folder on my computer. So I located the backup .umap save and replaced the level .umap as drummerof13 described. Immediately I am able to load up the missing level file I thought I’d lost. OK now I have a new problem- when I go to play the level to test it out, I discover that A- I am not being spawned at my player start. B- My third person pawn (Player) is not being spawned at all C- (Probably related to B) I cannot move or control the pawn.

I’ve tried pretty much everything I can think to do- Restart editor, delete and replace player start, delete and replace thirdpersonBP, etc etc. I am completely lost. any ideas? This issue seems to be too specific to yield any help from google searches…

Hi all!

I had the same problem today. Unreal had openned my proyect with an older version. Once I openned with the last version it solved by itself.

Hope it heps!

glad this worked for all of you. but as for me. NOTHING WORKS! isnt that fantastic. i’m losing faith in any avenue. all i wanted to do was transfer my project from one computer to another, but my ONE AND ONLY LEVEL isnt pulling up my new comp. i’ve tried everything…besides drinking poison. maybe i should do that. cuz nothing works.

2 Likes

I am having a similar issue and I know that it is not due to engine version.

I am trying to migrate a level and its associated assets to a new project to trim down file size. The current project is in 4.21.2 and the map loads fine in the current project. I migrate the level to the new blank project using the same engine version and the map is not visible in the content browser (but it is listed in the file explorer). If I try to drag the umap file into the content browser I get: “Failed to import: (directory location) Unknown extension ‘umap’”

FIXED by enabling Water Plugin + Editor Preferences: Procedural Foliage!

Just had this issue with migrating maps from a UE4.26.1 project to another UE4.26.1 so it wasn’t the UE4 version.

However, the project where I created my map used the new ocean spline and procedural foliage.

Enabling the water plugins and procedural foliage solved the issue so if you have the same issue check your plugins and project settings in the old and new projects to make sure they are aligned.

3 Likes

I just had this same issue. I’m importing my project from 4.26 to UE5. Everything showed but my level. I checked my plugins and forgot to enable “Water” (I also enable all other plugins) Once enabled my level showed in the content browser/draw and was able to load correctly

2 Likes

I had the same issue, as everyone who may be reading this. I couldn’t see my level in the content browser but I could see it on my file explorer.

FIX: When migrating a level to another project, make sure that you enable plugins that you have used in the level.

100% resolved!

This solution worked on my as well. I had to revert from 4.27 to 4.26 due to a bug in replication and the level was not loading. Bringing up the /Saved folder and copying the last known level to the content folder and then renaming it to what the initial level name was did the trick for me.

works like a charm ! thanks :cowboy_hat_face:

mannnnn thank youuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuu you saveeedddddd my asssss

this worked for me! thanks