Missing Info.plist value when submitting build to TestFlight

I am trying to test an ARKit enabled project, built for iOS 11 beta, using Xcode 9 beta 6 and UE 4.17.1, on macOS 10.12.6.

The build works perfectly fine (it is a Shipping build with Distribution and Full Rebuild checked), and I can upload the compiled IPA to TestFlight through Application Loader. However, when the IPA is processed by iTunes Connect, there is an error that is thrown:

Missing Info.plist value - A value for the Info.plist key
CFBundleIconName is missing in the
bundle
‘com.Example.AppID’. Apps
that provide icons in the asset
catalog must also provide this
Info.plist key. For more information
see
http://help.apple.com/xcode/mac/current/#/dev10510b1f7.

The issue persists even when I add the following key-value-pair to the Additional Info.plist field in the iOS build settings for the project:

<key>CFBundleIconName</key>\n<string>[REDACTED_PROJECT_NAME]</string>\n

I know that technically iOS 11 beta and the Xcode 9 beta aren’t supported; but I want to make sure this is a known issue so it can be addressed. I want to be able to launch this game during the iOS 11 launch window.

Any info on a workaround, and/or a timeline for a fix will be much appreciated.

Thanks!

If you build an iOS app using Xcode 9, add an App Store icon 1024х1024 in your UE4 project (“iOS marketing image” was added in 4.17), not iTunes Connect.

Hi Jonathan,

Sorry for not responding to your post sooner. Are you still having trouble with this issue?

Tim