Missing hostfxr.dll (.NET Core Runtime) When Creating a UE5 Project

I get the following error when trying to create a new Unreal Engine 5 project.

An error occurred while trying to generate project files.

Running D:/Apps/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool.exe  -projectfiles -project="D:/HD/Projects/Unreal Projects/AtlanticaWorlds/AtlanticaWorlds.uproject" -game -rocket -progress
A fatal error occurred. The required library hostfxr.dll could not be found.
If this is a self-contained application, that library should exist in [D:\Apps\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\].
If this is a framework-dependent application, install the runtime in the global location [C:\Program Files\dotnet] or use the DOTNET_ROOT environment variable to specify the runtime location or register the runtime location in [HKLM\SOFTWARE\dotnet\Setup\InstalledVersions\x64\InstallLocation].

The .NET Core runtime can be found at:
  - https://aka.ms/dotnet-core-applaunch?missing_runtime=true&arch=x64&rid=win10-x64

Installing .NET 5.0 didn’t work.
Repairing .NET 5.0 didn’t work.
Installing .NET Core 3.1.15 didn’t work either.

Unreal Engine is installed on the D drive instead of the C drive. Could this be causing this issue?

Update: 1:

The [D:\Apps\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool] directory does have “UnrealBuildTool.exe” present.

I confirmed that the [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App] directory has both the 3.1.15 and 5.0.6 subdirectories.

The “dotnet” registry directory is missing in [Computer\HKEY_LOCAL_MACHINE\SOFTWARE].

Update 2:

I’ve been getting this error while trying to create a C++ game project for PCs.
I tried creating a Blueprint project and it seems to work just fine.
I still need a C++ project for my game.
Does anyone know how to convert a UE5 Blueprint project into a C++ project? This could be my workaround.

4 Likes

Fix:

For anyone else having this issue:
Installing the .NET 5.0 and .NET Core 3.1 Runtimes did not solve this issue.
Installing the .NET 5.0 SDK didn’t resolve this issue either.
It wasn’t until after I installed the .NET Core 3.1 SDK x64 that I was able to create a UE5 C++ game project.

26 Likes

Thank you so much! I was actually having another somewhat related problem, in that I couldnt package a project due to missing sdk. Installing .NET Core 3.1 SDK x64 fixed the issue.

2 Likes

Thanks buddy, the editor does not specify which version to download :smiley:

1 Like

Download .NET Core 3.1 SDK x64 here: Download .NET Core 3.1 SDK (v3.1.409) - Windows x64 Installer

12 Likes

Thanks, I tried several .NET packages before without success, but installing exactly the “.NET Core 3.1 SDK v3.1.409 x64” solved the issue!

4 Likes

Thank you for posting, that fixed the issue for me.

I also found that the issue only affect C++ projects, I was able to create a Blueprint project.

I suspect that the UE5 Preview installer should be installing this, but is not, the kind of thing which might not show up in testing if the testing was done on a system that already had the Microsoft .NET Core 3.1 SDK v3.1.409 x64 installed.

3 Likes

Thanks man :smiley:

1 Like

So I fixed this by adding the .NET desktop development workload through Visual Studio, dunno if its as clean as the aforementioned fixes, but it works lol.

HowTo: open visual studio → Tools → Get Tools and Features → Workloads → Desktop & Mobile → check .NET desktop development → then hit modify

I left their default options as is.

4 Likes

That solved my problem, Thanks bro!

1 Like

get to the app data on run appdata and program data, those are hidden folders on disk C, delete all the content from there related to epic. then restart, then attempt to open.

or may be fresh start…j

Fixed the issue for me also. Thanks!

1 Like

I have tried all of these methods that I have found here but nothing works. I used to be able to create a c++ Project but now I can’t enter that project and I cant even make a new file.

even though i downloaded the version it specified to download it still won’t open a c++ file

Just ran into this while trying to generate VS project files for ACFUltimate project published by the team that released the ACF plugin. Ideally it would be nice to specify that you require a .Net SDK x64 to be installed in the section of the docs that shows pre-reqs here:

Also noticed this section is missing from the 5.0 docs.

1 Like

Where do I install the .NET Core 3.1 SDK x64?

1 Like

Thank you, this also fixed the issue for me.

1 Like

Great post. I just experienced the same issue. luckily I came across this. Please mark this as the answer for future developers looking for this info. Cheers

1 Like