Download

Missing bones while importing the same default mesh of a character

Hey guys! So I’ve tried to export mesh and it’s skeleton of the default mannequin so I could try to apply it’s skeleton to my character which I previously modelled in Blender but I’ve run into some problems. I tried to import default mannequin into Blender and then just export it in the same .fbx file but with different name. While importing the file, UE4 tells me that some of the bones are missing from the skeleton, and to be more specific, it’s 25 bones which all have name that ends with ‘_end’. Now that’s strange because when I open bone structure of the mannequin, it doesn’t show any bones that end with ‘_end’. Could someone help me please?

This is part of the list of the missing bones:

when you export from blender turn off the “add leaf bones” option.

hope that helps:)

I have no idea why, but it works now :slight_smile: Thank you A LOT smokey!
What are those leaf bones used for?

I’m now facing only this problem:

It’s a mesh imported from .fbx file which is a default mannequin.

leaf bones are required by some of the other 3d programs or software so that they know where the rig ends (i think) Unreal and blender don’t need them but it’s unfortuntet that they are on by default in the blender fbx exporter

I see now. Thanks Geodav!
Does anyone maybe know what causes the skeleton not to work because SK_Mannequin is missing? I’ve checked out the bone structure and I can’t find the bone named SK_Mannequin.

So apparently UE4 always shows me that bone with a name of the character mesh is missing. I renamed the mesh to ‘Character’ and I still get the message that UE4 can’t use the skeleton of the mannequin:

EDIT: I’ve found someting. As you can see from the image above the whole mesh and skeleton start from the Armature node in the hierarchy while the default skeleton is separated inside of UE4:

I need to separate mesh and bones in my blender somehow so the rig doesn’t start from ‘Character’. Insted it should be root I guess.

Okay so I’ve managed to get it working. I selected root and Character_group nodes and checked ‘Export Selected’ while exporting as .fbx file.

The armature object in blender is getting turned into a new root “bone” during export (for blendery reasons…)

You can treat this new bone as your new root bone, although technically it’s not a bone in blender. I’m pretty sure the guy who’s coding the fbx exporter in blender said it was a UE4 importer bug, but for now you can treat it as your new shiny root bone. To use root motion you will have to animate the armature object in blender (in object mode).

Thanks for your reply. I managed after long struggle to fix that issue yesterday.