Download

Missing Bones from bind pose, Help needed

Hey folks,

I created a very simple character for a racing simulator.
It has 4 bones.

B_Root
B_Bottom
B_Upper
B_Back

These are all parented to the root bone.
I made the character and rig in Blender, the only bone without any weights is the root bone.
However I get this warning when importing the skeletal mesh.

***Warning The following bones are missing from the bind pose:
B_Bottom_end
B_Upper_end
B_Back_end

This can happen for bones that are not vert weighted. If they are not in the correct orientation after importing,
please set the “Use T0 as ref pose” option or add them to the bind pose and reimport the skeletal mesh.


Can anyone explain why this happening, and how to solve it?

—Solved—
→ smokey13
there is an option in blenders exporter called “add leaf bones” that’s on by default, when its on it adds extra bones, turning it off will stop the extra bones being added and should fix your problem.

hope that helps

Yup that was the problem. Thanks a lot.

From looking at the skeleton in ue4.
It seems as though the Bones I am exporting all count as two bones. Where the tail gets renamed for some reason to “bone_Name”_end.
Except for the root bone.

How do i prevent this from happening?

there is an option in blenders exporter called “add leaf bones” that’s on by default, when its on it adds extra bones, turning it off will stop the extra bones being added and should fix your problem.

hope that helps:)

So yeah, apparently I forgot to check skeletal.
However, I am missing a bind pose now.
Any ideas how to add it to my fbx file using blender?

Bones werent imported, ignore this.

I have turn off add leaf bones, now my bones aren’t even exported.
I have no idea what I did, but I am not exporting my bones anymore.
Gonne take a 5 minute break

Ok solved the no bones problem.
Ready to venture on.

glad you got it solved:)

thank you sir.

Why didnt you say what the solution was have the same issue right now?!?!?!

In case someone is still looking for where to check the “Use T0 as ref pose” it is in the skeletal mesh advanced options, when you are importing the fbx to unreal.

Where is it located if the import comes from daz?

removing leaf bones makes an fbx without animation