Missing App Store Icon IOS

Hi, I am having issue with my packaged .ipa project. When I try to upload it via Application Loader, I get an error saying "missing info.plist value ‘CFBundleIconName’. However, I’ve already set the marketing icon in my project, also tried generating xcode files and set the marketing icon there. No matter what I try it keep popping me with this error. It appears to me this is something related to 4.22. Because I already have an accepted version of the app. And I have no chance to roll it back to older unreal versions. Thanks in advance.


Edit: Just tried building a project with 4.19 and trying to push it through application loader. It gives out the same error. Could be something related to xcode version. Still waiting for a solution though.

Changed macbook air to macbook pro and installed xcode 10.1 with UE 4.19. Now it’s fixed. No more error. I can upload it to app store and it passes the review.

4.22.1 still have this issue. Package shipping for distribution build right now, have this trouble.

Fixed! UE-73066 iOS app icons appear blank on device for C++ projects packaged from Mac - not fix this.

Did you finally successfully built it on 4.22?

It does not work for me on version 4.22.1 of the launcher.

They have reopened a old case to track this bug: Unreal Engine Issues and Bug Tracker (UE-50162)
Please vote for it to get it fixed.

Same issue here, UE 4.22.1, Xcode 10.2
Do anyone have some kind of workaround?

I send to epic bug report about this issue. Unreal Engine Issues and Bug Tracker (UE-50162)
Vote please

Same problem here with UE4.22.2. Project is built on a W10 pc through the UE4 remote build process. 13" retina MacBook Pro from late 2015 as a compiling server running Mojave (10.14.4) with XCode 10.2.1.

Same here. Remote building on Windows. Using 4.22.3

Everyone vote for them to fix it!

Hi guys,
after countless hours of frustration, I finally found a workaround!!!

You have to go to project settings → iOS → Additional Plist Data and add the following:


Be sure to insert it without any new lines. Thats it.
With this plist modification it can be uploaded after building.

In case you have an override for ios in Config/IOS/IOSEngine.ini look for
AdditionalPlistData= …
And replace or add the … with the line from above.

Hope that helps you to also fix the mess.

It worked! I was able to upload to the app store successfully. Thanks!

This solves it on 4.22.3. Thanks. I can’t believe how epic doesn’t help in any way about this.

you are a hero!

I am getting this issue as well. I can not find the “project settings” in order to add all of that, unless I am completely blind. I am using a macbook air, does that affect anything?