Download

mip levels blur our instantly.

For some reason my models textures get really blurry … like through all the mip levels in like a very short distance… like u can have difficulty even getting to one of the mid mips because they change so quickly… and obviouslly it looks like **** cause I cant even see my texture from normal range.

The weird part is … sometimes reimport might fix it for the next 5 minutes … sometimes relaunching unreal… but it always comes back.

The fbx exporter in maya is set to cm to get the correct size of the model in unreal. Anyone have any idea why the mip levels are doing this?

Take a look at this thread: how to disable texture blurring based on a camera distance form object? - UE4 AnswerHub :slight_smile:

“Open the texture in the content browser and extend Texture section(click the little arrow) in Details panel, then enable Never Stream”
“If you want more control over texture streaming check BaseEngine.INI”

I’ll check that out thanks.

curious, but does this hurt performance in any way?

it does since it needs to process more texels and also increases artifacts/noise.

As divi already mentioned, it will hurt the performance ->

“Never disable mip maps if the texture can be seen in a smaller scale, to avoid slowdowns due to texture cache misses.” (Performance Guidelines for Artists and Designers | Unreal Engine Documentation)

Is that what streaming is? mip mapping? or are the 2 seperate things. I do not want to disable mip mapping. Is tehre a way to adjust the distance the mip changes if this in fact is mip mapping?

bump! Anyone have an answer for me? Disabling mip mapping completely isnt an answer in any useable form. As i said most objects stream correctly. But so far i noticed this issue on a character with a skeleton .

Still no answer for me… any more info on this BaseEngine.INI? I found nothing on it… and my skeletal meshes still blur like hell from a meter away… and only get a sharp mip at like right on their face… looks like ****. I need mip mapping so disabling streaming doesnt seem like an option… Unless streaming isnt mip mapping… which i have no idea. Cmon… these seems like a pretty HUGE problem here… someone has to know something.

I cant even find that BaseEngine.INI file.

Any forum moderators or developers of the engine able to answer this? The lack of support seems scary.

I changed streaming distance multiplier in related character components for skeletal meshes or actual meshes in Persona to resolve it. Increasing the value increases the multiplier of the bounds or something, and that seems to also increase the range at which mips are streamed (ergo, streaming multiplier). They still have a tendency to snap in when you move up to an object, though. I wish there was greater control over that to make the loading much more aggressive when you approach objects so you can’t see the pop-in without using a super high multiplier.

Thanks for that info :slight_smile: