Download

Minimizing any UE4 window locks up my computer

I found a bug that causes UE4 to lock up my computer when I use a specific material I made. I was trying to to make a post-process material that gives me the light values of the scene.

In my first attempt, I divided the scene color by the base color. It gave me the light values for most of the scene except the parts where at least one of the base color’s RGB values is 0. If one of the base color’s RGB value is 0, it would give me a pitch black model with a colored outline depending on the 0 value. So to fix it, I tried clamping 0 to 0.000001, which fixed the previous problem, but gave the light value a slight tint of the 0 values.

What I tried next is what locks up my computer. I made this material:

755eb1f2be79649678ce951d2f24abfb88fbcc77.jpeg

What I wanted to do was if the the RGB values are higher than 0, it would do the scene color divided by base color thing I did before, but if it is 0, then do something else. I was gonna try different things for the 0 result, but I wasn’t able to experiment due to the lock ups.
Building the material and using it in the scene doesn’t lock up my computer, it’ll show the results normally on the viewport. But minimizing any UE4 window causes my computer to lock up, even if I disable, change or delete the material afterwards. I can have that chart somewhere in the material, and as long as the results aren’t connected to the output or you never load the results from it, it wont break.

This is discouraging me from using UE4 cuz, I’m afraid of how else I can break UE4, especially when I needed to start the project all over because building the lighting crashed UE4 and none of the fixes I found did anything.

EDIT: Nevermind, UE4 seems to crash regardless of what project Im using and the material file became corrupted and does not show up in UE4 but its still in the folder.

Here’s my specs
System Manufacturer: MSI
System Model: MS-7751
BIOS: BIOS Date: 10/24/12 17:02:19 Ver: 04.06.05
Processor: Intel(R) Core™ i7-3770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory: 16384MB RAM
Available OS Memory: 16334MB RAM
Page File: 4497MB used, 28170MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

      Card name: NVIDIA GeForce GTX 670
   Manufacturer: NVIDIA
      Chip type: GeForce GTX 670
       DAC type: Integrated RAMDAC
     Device Key: Enum\PCI\VEN_10DE&DEV_1189&SUBSYS_26703842&REV_A1
 Display Memory: 4038 MB

Dedicated Memory: 1990 MB
Shared Memory: 2048 MB

Hi Admiral Skye,

I’m sorry you’re having this issue. Can you post this on the AnswerHub in the “Bugs” section with all the details here? Thank you for being very thorough and detailed as well!

When you do post this on the AnswerHub can you also include your crash report in an attached text file?

Thank you!

Tim