MiniMap Widget edge transparency issue

I’m running into a issue that I’ve been stuck on for about 8 hours… actually its taken longer to figure this out than it was to code my fog of war logic.
I can’t for the life of me figure out a way to make the edge of my minimap be transparent when i add my fogofwar opacity.
When I use my Map texture for opacity it works, but when I plug in my Fog of war it bleeds a solid color. Any help would be greatly appreciated.

Bump still need help with this, let me know if you need more information or clarification.

Porfavor, spanish for pleaseeee =P

Anyone can help? I cant figure out why my texture bleeding/mirroring at the end of my minimap widget. I tried messing with all the clamp,mirror, wrap and nothing changes… i tried tweeking the texture render target and uvs nothing… maybe im missing something obvious or ?

What happens when you

  1. plug the output of the Multiply node directly into the UVs pin of the FOW texture (those other nodes are for zooming and rotating the mini map I assume) and
  2. plug the FOW texture’s R pin into Opacity instead of the entire RGBA?

Hey And!
Thank so much for replying, really appreciate it. Was starting to wonder if the community was dead.

  1. The same effect happens but my fog of war rotation is not correct since it needs to be rotated
  2. Same solid color effect happens when I plug the R pin.

I even made a square alpha in photoshop for the texture to see if i mask out the last pixels to transparent, to see if it would mirror those pixels to be the transparency and it just does the same effect. Really cant believe it, after so much trouble shooting i cant figure it out.
As you see from the first picture, if I use the Map texture it uses the transparency and bleeds it to the entire widget correctly… once I introduce the fow in the opacity it just decides to extend a solid to the edge of the widget.

Another thing I can think of is playing around with the texture settings. The FOW is probably a render target, right? If that’s the case, can you open the asset, look for the “Clear Color” option and set that to a completely transparent color?

Hey And, thank you for the brain storming help… your advice indirectly made me start to fiddle with the FOW texture, which you are correct is a render target. I fiddled with the settings and nothing changed… but I started to think about the material that was rendering the FOW texture, I hadn’t touched the opacity of the FOW material… So i plugged in my 5 pixel border alpha… into the opacity of the FOW material to see if it tiles the edges and boom it worked! Only took 14 long hours.
Thanks again And.
Also added some pictures just incase this helps anyone in the future.