Download

migrating from old modding environment to new launcher dev kit

Anyone try this yet? I downloaded the 50+ gigs of data 3 days ago and now they’ve decided to integrate the kit into the UE launcher with what I assume is an update to the kit. Or is the steam dev kit still getting updated (minus the github files?)
Does the UE launcher include everything needed now, including the github files?

oh they did add it to the ue launcher?

didn’t open it much since ark launch ^^

but if it did dl 50go it seem that it’s complete, i don’t see why when passing by the UE launcher we would need the github file but who know ^^

oh seeing this it seem that the update v200 is live now :stuck_out_tongue:

and the dev kit did update on steam :o

they just change the bat file to redirect you on the tuto page for the dev kit where there is that :

A: You can get the ARK Dev Kit directly from the Epic Games Launcher. Simply Sign-Up, Download Unreal Engine, and go to the ARK tab!

it seem the dev kit on steam will no more be update ^^

Hey Nano,

You will have to backup your mod’s folder and just move it over into the new Dev Kit installation via the Epic Games Launcher.

Example: I copied Canna_Ark-Light (the folder right out of the mod folder) into the new mods folder in the new directory. It should work without any issues :slight_smile:

No more manual github updating & no more steam for the Dev Kit AT ALL! :wink:

Cool, so today will be the last time I copy github sources and break my devkit :smiley:

You shouldn’t need to update the binaries at all anymore, just grab the Dev Kit off the Epic Games Launcher now :wink:

Something is not working right. The new dev kit from Epic Launcher uploaded my mod but with different publisherId so I deleted it off the steam workshop page so people wouldn’t get confused on seeing 2 of the same mod. Now, the dev kit won’t even upload my mod at all, it keeps saying error failed to update workshop item (file not found) and the file hasn’t been moved, smh. Anybody else have this issue or maybe knows what’s going on?

salcarr, people did have this issue before too, you will have to look in your modfile.vdf and change id here or something like that look in the sticky post there is a post with this issue :wink:

for the error in uploading, same thing some people have this issue search in the post to find the topic i’m not sure if the solution was found or not ^^

Im getting this issue as well. I tried following the steps in the sticky, and i also tried changeing the ID in the vdf as well as the mods.db but it kept reverting and createing a new workshop item.

The only ‘fix’ i found was to change the ID’s to your existing workshop ID and then make the files READ ONLY before uploading. This updated my old workshop item as i hoped, but then after unchecking read only it would start reverting to a new item again :frowning:

@Bacon_Beard thanks for the info, that fixed it. I didn’t realize about the mods.db so it was conflicting ids for some reason even though just like you it would revert to new ID. Therefore, I changed both IDs to my old one and then changed it to read only. Now it uploaded my mod. Thanks guys, hope they can fix this so that I don’t have to keep repeating this process forever lol

Nevermind, I changed the mods.db to my old one and it fixes everything. No need to apply read only, it will upload the way it should, OH YEA :cool:

Mine reverts every time still, or gives a File not found error - no idea why :frowning:

Hmm, thats strange. The mods.db reverts also? Do you have the editor up when you do it?

Most times I closed the editor. I tested it at least 10 times though and tried with editor open a couple of times

If you’re still having trouble, try copying the mods.db from your 193 folder to your new folder. That worked for me.

Editing a .db file with a text editor shouldn’t work, and didn’t for me.

try https://forums.unrealengine.com/showthread.php?77634-Quick-Note-How-to-manually-override-the-Steam-PublishedFileID-for-your-Map-Mod&p=342590&viewfull=1#post342590

try that it should work wonders for u <3

Thanks. It looks as if it will work, however I’m now getting ‘Login Failure: NO Connection’ Error while trying to upload. Couldn’t upload a couple of days ago due to it - thought it was a port issue, but it started working again yesterday & not its stopped again. I really hope we will be able to upload the same we we could before it was all through steamcmd lol :slight_smile:

i have to do it manually the actual indev uploader wont work