MIDI Device Support: Getting 'None' when trying to access the MIDIDevice Controller value

I’m trying to utilize the MIDI Device Support plugin and I have my blueprint sent up the following way:

However when I try to run it, I get this error:

‘ExecuteUbergraph_MIDIPROJECT’ from node: Bind Event to OnMIDIEvent in graph: EventGraph in object: MIDIPROJECT with description: Accessed None trying to read property Midi Device’.

I’ve tried a Print String off of the ‘Return Value’ pin on the ‘Create MIDIDevice Controller’ node and it’s reading as ‘None’. Any help would be greatly appreciated.

I struggled with this a bit too. Turned out that it was something weird with my device drivers and once I’d sorted that out everything worked quite well. For reference, here is a debug blueprint that I put in my level blueprint. It lists all the devices recognized as midi, tries to make a valid MidiDeviceController, then tells you whether that was successful. Then it attaches a debug event. Works on my setup - Win 10, UE 4.16 pre2, Allen & Heath Xone:K1.

Or copy and paste this pastebin code: Native Midi plugin debug posted by anonymous | blueprintUE | PasteBin For Unreal Engine 4

1 Like