Microsoft.MakeFile.targets(45, 5): [MSB3073] exited with code 6. error

Hello everyone,

I am receiving the following error on when trying to build a fresh game with UE5 using Rider. I was receiving the same error when using VS2019 with UE4.26. I have done some research online regarding the error and what others that used to troubleshoot, but I am still at a loss to determine how to fix the error.

Any help provided would be tremendously helpful and I know would help others in the community.

Thanks!

4 Likes

I was having issues with UE5.0 source build so I deleted and re-downloaded UE5 Early Access. Getting this same error now when trying to build my Project I started with 5.0

1 Like

Did you find a solution?

Have you found a solution to this?

I had the same error. Resolved with checking in the project the last changes i’ve made and actually i wrongly used “UFUNCTION(Server, Reliable)”. hope this helps

Had the same error.
It was because I installed RiderLink plugin as a UE5’s engine plugin. Apprently RiderLink preview has a bug, and it only works as a per-project plugin.
Removed the RiderLink folder from UE5’s engine plugin (Plugin/Developer/RiderLink) and reinstalled it in the project folder. And the project was finally built.

More here: Unreal Engine 5 - Jetbrains Rider Early Access - YouTube

4 Likes

Had a similar error and the issue was a file that Rider was trying to write to that was not checked out in Perforce and thus read-only on disk.

Rider somewhat unhelpfully collapses the error log into just that message, but you can expand it with a button on the left.

Hi!

I believe that found the problem, if the Live Coding configuration of integration is enable in your Unreal Engine 5, can be this that are creating the conflict of Mutex :eyes:

Try disable the Live Coding or press Ctrl+Alt+F11 in the editor(VS2022) or game, and try compile again.

This information are in a log file from Unreal Engine 5 in:

USERNAME/AppData/Local/UnrealBuildTool/Log.txt

See below the complete message:

Checking for live coding mutex: Global\LiveCoding_D++Epic Games+UE_5.1+Engine+Binaries+Win64+UnrealEditor.exe
Unable to build while Live Coding is active. Exit the editor and game, or press Ctrl+Alt+F11 if iterating on code in the editor or game
BuildException: Unable to build while Live Coding is active. Exit the editor and game, or press Ctrl+Alt+F11 if iterating on code in the editor or game
at UnrealBuildTool.HotReload.CheckForLiveCodingSessionActive(TargetDescriptor TargetDescriptor, TargetMakefile Makefile, BuildConfiguration BuildConfiguration, ILogger Logger) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\System\HotReload.cs:line 231
at UnrealBuildTool.BuildMode.Build(TargetMakefile Makefiles, List`1 TargetDescriptors, BuildConfiguration BuildConfiguration, BuildOptions Options, FileReference WriteOutdatedActionsFile, ILogger Logger) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Modes\BuildMode.cs:line 526
at UnrealBuildTool.BuildMode.Execute(CommandLineArguments Arguments, ILogger Logger) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Modes\BuildMode.cs:line 242
at UnrealBuildTool.UnrealBuildTool.Main(String ArgumentsArray) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 648
WriteFileIfChanged() wrote 0 changed files of 0 requested writes.

have many more informations, but are personal information from my project and path from ssd :smile:

3 Likes

I just wanted to add an update as I had a similar issue this weekend using UE5.1

According to this link there is a known bug with UE5.1 and Rider. To recap the explanation in case that link gets lost :

" This looks like a known issue in the MSBuild detection mechanism. Please switch between x64 and x32 versions of MSBuild manually and let us know if the issue persists.

To switch between toolsets, please open Settings | Build, Execution, Deployment | Toolset and Build and switch MSBuild version from <VS install path>\Msbuild\Current\Bin\amd64\MSBuild.exe to <VS install path>\Msbuild\Current\Bin\MSBuild.exe"

After a long weekend of searching and brain scratching, I did the recommended fix and it solved my error! Hope this helps somebody!

1 Like

Removing the .vs, .idea, .vsconfig, Binaries, Intermediate, Saved, DerivedDataCache and the rider solution and regenerating them by right clicking on the .uproject file and clicking on “Generate Visual Studio project files” fixed this issue for me

1 Like

In my case that problem was caused by having editor open and trying to run the code at the same time.

2 Likes

That solved it for me too!
Had VS open and wanted to compile while being in the editor in another project.
I don’t use Rider so this was the most likely solution.
Thanks!

1 Like

On a C++ project on UE5.1.1, I fix it with this two options:

And be sure you have closed any UE instance.

1 Like

Little late here, but had this issue on 5.2. Turning off live coding solved my issue.

2 Likes

In the log I could see something with UPROPERTY issues and I found out that in my case I just had a “UPROPERTY() float…” without anything in the brackets, which cause this error to occur. Adding a BlueprintReadOnly fixed it.

1 Like

By default LiveCoding is enabled which means you compile from UE5, not from your IDE. Trying to build from VSCode or whatever will give this error.

Save your code, go to UE5, hit CTL+ALT+F11 and it will build your project from there.

1 Like

how do we do this ?>??? please give steps on HOW to turn off live coding, is it in VS is it in UE??

when you have deleted “VisualStudioDTE” folder, it does not work. Restart your compouter

My issue was that I had improper UPROPERTY definition :smiley:

More specifically I was defining a component like this in my header file:

UPROPERTY(Category = “AI”)
TObjectPtr BlackboardComponent;

It turns out that you can’t just have a UPROPERTY with only a Category. Once I added “EditAnywhere” first, then it was all working again.

UPROPERTY(EditAnywhere, Category = “AI”)
TObjectPtr BlackboardComponent;