Metahumans and level sequencer.. why so painful

Looking for some advice.
I am trying to create a basic level sequence of one of my MetaHumans and I am having so much trouble with additive control rig adjustments.

Basic workflow:

  1. Create level sequence
  2. Drop in my MH (either spawned or direct from map - doesn’t matter which)
  3. Remove control rig from body
  4. Add a nice animation sequence to the “body”
  5. Bake animation to MH control rig
  6. Add additive track to the control rig so I can adjust to animation track to exactly what I want.
  7. ARGGGGGGH… stop removing my additive changes every time I save the level sequence (yes I am keyframing the changes)
  8. Delete all and rinse and repeat 2-7… more arghh…

I simply cannot seem to get the control rig changes to stick.
I also hate how I have to keep enabling the ik contols on the additive every time I want to move ik handles around.

Has anyone successfully created a nice level sequence WITH additively changing the baked animation via the control rig. (A tutorial would be awesome - I have to be doing something wrong).

Thanks in advance…

PS: Epic Games… outside of the above I am LOVING Metahumans, I won’t use CC3 again I don’t think, even despite the early release limitations.


Ok so the plot thickens… it seems that the additive control rig track actually does nothing at all :confused:

I have found that if I bake an animation to the control rig and then add an additive to the control rig (with the little + ) then whenever I adjust IK controls on the additive control rig layer, NONE of the addiditve values change. It seems to only change the top control rig layer (the keyframed layer).

I guess now, has anyone had success with an additive layer on the control rig and how did you get it to change the values and have them stick when saving.

Come on Unreal friends… SURELY someone else has experienced this issue with so many people trying Metahumans.
There must be someone out there that has found the one thing that solves this LOL.

@EpicStaff … maybe someone from your great animation team could chime in here

1 Like

Are you using UE4 or UE5?

Hey @scottunreal I should probably have mentioned that hey… 4.26.2

I have been working on it more today and I think I might have discovered the problem after days and days… I think I can just manually key the changes at the additive level, my issue appears to be when I have autokeying turned on… which is a pain, but if it is what it is I can at least live with manually keying.

ANy follow ups here? RUnning into issues with additive tracks not doing anything when overlaid with animations.

1 Like

I have been using additive tracks lately and haven’t run in to any issues, all seems to work ok for me, the only thing I can think of is that when you select something on the control rig in the viewport it selects both the original and the additive, I always then select just the matching control in the sequencer so the original isn’t selected as that was giving me issues, have you tried that?

1 Like

Will give that a try. But there also baked animations playing. And adding the control rig to adjust one of them, overrides them completely back into A Pose.

You have to bake your animation to control rig and then add the additive, even if this was a previous animation you baked.

Add the animation to the MH in sequencer and then right click the body or head and chose bake to control rig, you’ll then see the option to chose the MH control rig. Once you have the new controls rig add your additive to that control section, either face or body, use the bottom sets of controls to key your additive in.

Let me know if that works?

1 Like

Before adding control rig (or setting it to inactive)

After adding/enabling

I understand baking it to the control rig but am unable to just get it to adjust an existing pose for in between animations/during. …
Oh. wait… I think i might get what you are saying now. Going to try it lolz.

Well it did something. Although now the controls are offset from the body.

Controls don’t actually move things around. @thehemsley
key framing things also has no affect.

Once you have baked to control rig delete the animation which is in there, then add the additive. Try that, if just tested it, if that doesn’t work and if I can upload a video here without uploading to YouTube I will. If you’re still having trouble.

1 Like

I got it working my dude!

I had to have the control rig removed before baking. Then could bake it, add additive track. adjust via second MH control rig. I will say its annoying not being able to select the controls in the viewport - despite hiding the original ones.

Oh also if you have to set your arm and leg ik/fk in the additive to match the original.

Cool, glad you got it working, don’t forget to match the ik/fk in the global_ctrl. :call_me_hand:

I did!