Metahuman head rotation lost when bake to control rig

Following with metahuman sample project I recorded a facial animation with ARKIT including head rotation. If I bake this animation to the control rig, the head rotation is lost. Is this a bug or how can I recover this?

Did you find a way to do it? Or did you animate it manually back in afterwards?

yep same here

Same here in 4.27, I am very interested by an answer to that issue :slight_smile:

In fact, the head rotation is not lost. When I preview the animation in the animation window, I can see it being played.
But, the Metahuman head doesn’t play that rotation when the animation is being put on the timeline.
Also, if I right click on the animation clip in sequencer, and press “preview skeleton” I can see the head rotation data being played on the skeleton. They’re just not played on the mesh, and that I don’t know why

1 Like

Ok, I’ve found out why. You need to go in the animation property clip in sequencer, and press" force custom mode"


When I do “force custom mode”, combining a body animation clip does this:

Force custom mode just lets you play the animation sequence, but the problem here is keeping the head rotation after baking it.

Yes same… I found a workaround.
As I use a metahuman face, but a body based on a UE4 skeleton. I made a custom AnimationBP for the UE4 Skeleton so it can get Arkkit face rotation data. Then I bake the head rotation on the body.
Then I Convert the body animation to FK Control rig on the timeline, same for the head rotation, and I merge both with and additive FX Control Rig.
Finally I bake animation again to have the body animation clip with the head rotation recorded from ARKit.
That’s quite a long process but it works.

1 Like

In your first step, when you bake the head rotation on the body, do you mean “baking to animation sequence”?
When I bake to animation clip with the body and live link data, on a default Metahuman BP, it does not get the head rotation data, but the Face does when I bake that. Perhaps the difference in blueprints is causing this.

Just wanted to hop in here and say that this force custom mode thing worked for me! I’m using the take recorder, so I went to the FACE animation and hit force custom mode. Lifesaver!! Thanks so much.

Thanks a lot. It worked for me.

Thank you! You’re a life saver.

I found it a bit difficult to understand how to turn this on. For anyone else in the same boat, you right click the actual clip on the timeline, then go to properties, then check the checkbox:

Why in God’s name it’s so hard to get really basic stuff working I’ll never know…


Hi, I don’t quite get how you baked the animation, any chance you coud explain to me your method in depth?

Hey :slight_smile:

I didn’t retry it for month but here is what I remember:

My character has a UE4 skeleton body, and a Metahuman head.
I have my recorded facial clip, when I preview it I can see my facial animation and my head rotation.
But when baking the animation, the head rotation information gets lost.
From what I understand, that’s because the head rotation is controlled by the animation played by the UE4 Skeleton, not by the metahuman head.

So I created an animation blueprint based on the UE4 Skeleton, and I copyed/rebuild what was in the metahuman BP concerning the Arkit.
In order to have my UE4 Skeleton able to preview my recorded facial clip (even if it doesn’t have the blendshapes, it will play the head rotation).

Now I can bake the facial animation on the UE4 Skeleton, in order to have an animation clip with the head rotation

When this baked animation is on the timeline, I right click on it (or the track name, I don’t remember exactly) and convert it to “FK control rig”.

I do the same with the animation I wanted to use originally on the body.

In order to have these 2 animations being played in additive simultaneously by my body based on the UE4 Skeleton , I right click on the character in sequencer (or the animation track, I don’t remember, try to right click on everything you can ahah) and add an “additive FK control rig”. That way you can have 2 animations tracks, one with your original animation, and one for your head rotation.

I hope that will help you!

I’ve answered directly to my previous post :slight_smile:

Heads up with anyone else trying to get the head rotation, if you look in the animation clips for the recorded take, the clip for the teeth actually has the head rotation in it.

Worked for me, thank you!