Download

MetaHuman Hair Clipping

Hi there, I’ve just imported my first metahuman into a project in UE 4.27 and have come across this weird issue with the hair grooms.



Its a bit hard to tell by picture but essentially there is this ring/wave like clipping that happens. The closer I move to the model the smaller the rings get and the further away I move the larger they get. if your just a few feet away the ring is so thick that it basically clips half the hair or more off the model, eyebrows and mustache included.

This only happens to the hair Grooms, the helmet and hair cards render just fine. I’m just wondering if anyone else is having this issue and if there might be a fix. There is a lot of pre built stuff with these meta humans and I’m not really sure where to begin.

also I thought it might be worth mentioning that this is just the Nasim Model from the base MetaHumans Presets with some different clothes.

update - I have imported this same model into a fresh project and the issue hasn’t been replicated so I am assuming this must be some setting or something that I have altered in my current project that is causing this. I wonder what it could be? :confused:

Fixed! - I found the problem, once I narrowed down that it was just this particular project that was having troubles. I then realized that I had previously set the near clipping value in the project settings to a really low number so I could view another object’s details close up. This was affecting the way the hair grooms were displayed so I set the value back to a normal amount and restarted the project and it was fixed.

This may be a very unique issue but hopefully it helps some others if they find themselves in the same situation.

1 Like

Hi Men, Check This Video. https://www.youtube.com/watch?v=vMeyTJYmFp8&t=409s&pp=ugMICgJlcxABGAE%3D

thanks! some cool little tricks in this video may use it later for changing up the cloths.

Fixed! - I found the problem, once I narrowed down that it was just this particular project that was having troubles. I then realized that I had previously set the near clipping value in the project settings to a really low number so I could view another object’s details close up. This was affecting the way the hair grooms were displayed so I set the value back to a normal amount and restarted the project and it was fixed.

1 Like