Metahuman hair chopped off

I’m trying to use my metahuman’s hair without changing anything (as far as I remember). I keep getting this clipping / chopped off effect though.

I’ve tried tweaking every setting I can find, but I can’t figure out how to fix this. Any ideas? It happens even from far distances.

Alright. I’ve no kidding been fighting with this stuff for weeks. I’ve put in probably 8 hours straight today working on this, and I ended up figuring out a solution that I think mostly works. I’m sure I’ll find it broken tomorrow or something, but I wanted to at least leave breadcrumbs for anyone else who may find this perhaps via a search engine.

For one: the LODSync component inside my metahuman’s blueprint was useful. There’s a “Forced LOD” field you can change from -1 to 0 or 1 to prevent your hair from disappearing when the camera moves too far away. This worked fine for me, except I had the issues mentioned in this thread.

To fix the issue above, I deleted the hair groom asset from my metahuman’s blueprint. Then I added a new groom component underneath face and selected my groom asset (Hair_S_Messy for me). Then I rotated it around in the view and positioned it back in the right spot on the head. Then, under parent socket, I clicked the magnifying glass and found “head” and selected it. Now the hair would stay on my character’s head even when animated.

Now the problem of the disappearing hair happened again. I think this is because LODSync is unaware of my new groom component, but I’m too tired to verify that. The solution I found at the bottom here ended up working. Quoting it, incase it disappears into a black hole: “Open Hair Groom Asset And in the LOD Section Set The LodSelectionType From CPU TO GPU”

Still, my hair looked like crap up close; I could see the scalp underneath the head all over. I went into the groom asset and doubled the “Hair Width” from 0.01 to 0.02.

Oh, and I also disabled Simulation under the physics tab on the groom asset. Otherwise my hair goes absolutely nuts. I’ve seen a ton of threads about this, with nearly everyone having the same issue. I don’t know why it’s the case, or why this stuff is so buggy, or why I had to do any of this, or why unreal, the universe, and God himself all hate me so much. But here, after 8 hours, my eyes bloodshot, I finally have figured it out. I hope it helps someone else. Wish me luck – I assume I will be struck by lightning after submitting this.