Metahuman error after using take recorder

My problem is that when I finish metahuman animation with livelink app + take recorder in Unreal, it creates a copy of my actor with animation attached, and it looks weird (see screenshot). While animation itself looks good, the body of my characted is rescaled and head is moved to wrong position. Can it be fixed?

1 Like

I want to update this topic: I tried a premade Metahuman “Kristofer” and got the same result, while other models based on female body for instance are being recorded without any issues in take recorder. Currently I am downloading another male model to test it, and check whether this issue is persistent for all male models or happens only to metahumans based on “Kristofer”.

1 Like

I have now also posted this as a Glitch…were you showing with UE 4.26, or UE5, I am guessing based on your timeframe of post it was UE 4.26?

Mine was for UE5, I was thinking this was a glitch for UE5 specifically. But in any event, it is good you brought this up as it is still present in UE5, unfortunately.

Also, more than anything, I am sorry you had to experience this nuisance while creating…frustrating indeed!

1 Like

Yes, seems like this is some kind of glitch within the Metahuman Creator, not with the engine itself, if this still shows up in UE5. My example was made using UE 4.26, after recording in Take Recorder and then opening it with Sequencer for animation.

Set your metahuman skeleton retargeting options to (from top to bottom of the list):
Skeleton (the rest).

You’re welcome

Isn’t it
Animation Scaling
Skeleton (rest)

k1lly - did someone in Qixel tell you this, because the Female and Male have the same retarget layout selections, yet the female works right and the male does not per mine and Tommygun999’s testing, so why would changing this then make it work:



And are you referring to setting Root, Pelvis as ‘Animation’, and then Spine1 + the rest as ‘Skeleton’?
I ask these because you posit as if you distinctly know it to be the solution.

Suggestion by k1lly does not accomplish anything.
Qixel also did not test with Take recorder or Sequencer.
Had they, they would have seen the glitch occurring and would have brought up to Epic developers to fix.

1 Like

I think I got a workaround, if ya’ll are still having trouble. In your exported animation sequence asset, set retarget source and asset. I chose the same assets as the non-retargeted anim here, but it also worked fine when selecting pretty much any metahuman asset.
I’m not 100% sure, but it appears the warped proportions might match the standard Unreal Manny Skele (see pic below), my theory is that when baking an animation sequence for certain metahumans, it baking it to the wrong skeleton, and you jut have to re-target it back to a metahuman to correct the proportions.

L (retargeted anim) M (baked aset / no retarget) R (default Manny)

1 Like

Thanks for your post. I had luck by opening the sequencer and double clicking into the embedded sequences to get to the point where I could see “Body” as one of the layers. Setting weight to 0 resolved this.

1 Like