MetaHuman Cloth (Long Hat) doesn't work right

Hi! Sorry for my bad english. It is my first unreal project.

I have:

— Metahuman
— Purchased animation from UE Marketplace
— Custom clothes.

So. I added clothes to MH. I created new sequence and added into it my MH. I deleted body rig and then added animation. When I play animation all clothes working fine. As I added MH skeleton and weights. BUT. My «long» wolf hat doesn’t work right. When animation is playing the hat stuck into body. But it should move with shoulders.

My Hat:

I spent 10 hour to solve this problem. What I tried to do:

— Connect hat with head bones
— Connect hat with body bones
— Do not use bones
— Use automatically bone when you upload mesh to UE
— I used head weights
— I used body weights
— No weights
— I created clothes simulation

I tried around 20 different variations.

— When I attached hat to face and socket to head — the hat stuck into shoulders

— When I attached hat to body and socket with clavical_out_r it stick to body almost right, but when animation is play — The Hat doesn’t move with Head correctly.

— When I create clothing simulation it looks good in Clothing window, but nothing change in BP and viewport and hat still stuck in body.

— I tried to attach hat to Body, To face, To torso. I tried aroud 5 different bones as socket.

I compare the bones of head and body. And the part where the hat is stuck has the same bones and with Head and with body. So I really do not understand why hat is stuck into body. And Also why clothes simulation do not works. I nearly give up. But I have to solve this problem as soon as possible.

Thank for any your advice.