Download

Metahuman - Blender

I want to create my own character creator inside my game, but start with the Metahuman model from the Marketplace, so that I have all the facial animations. I tried to export the FBX from UE4 to Blender, but the face’s vertices are completely messed up, does anyone know why?
Is what I am doing allowed and possible? I want to modify the character with Blender, create shapekeys, and have them work with Metahuman.

i think you have all the levels of detail showing at once the far levels will cut through the nice one making it look bad go to edit mode making sure you dont have vertex proxy merging turned on
L to select an island and hide each lod i wouldn’t separate them unless you know what your doing as could mess up the animations you get the same lod merging with the paragon characters if you import into blender might be down to the way they were created possibly auto generated in epic??? Gona do some experiments with lods see if its true if so might even be able to delete lods and just use engine generated lods on re import

Inside Unreal, go to Metahuman_004_Facemesh and scroll down to LOD Settings and set Number of Lods to 1 (don’t save unless you want to lose the LODs). Then you can import the mesh into Blender. However, a problem I have in Blender is the Material slots seem to be gone, whereas usually when you export from UE they’re still there. Let me know if you have that issue as well.

2 Likes

hi I didn’t see how bad it was or fully understand what was going on from the first pic but as DenRunner said this fixes the messed up verts i have the material slots (just need to add the textures manually) but no key shapes export materials on the export option easy to just blast past clicking ok without checking all the boxes:) we’ll get there lol … still looking into it doing some fiddling about

You have to make sure to check off “Export Morph Targets” on the export screen or else you won’t get shape keys… dang wish mine would have material slots after loading it into Blender, like other exports from UE4. I know the material slots are in the FBX file, because when I rename and immediately reimport the FBX into Unreal the materials are there (minus the LOD materials of course). But as soon as it gets into Blender they’re gone, and when I save and reimport in unreal I only get the skin and nothing else.

Are you using any special settings for the import other than the usual? I’m using Blender 2.91.2 by the way… was on 2.91 before but upgraded hoping to fix it… nope.

Thanks! You’re right it did fix the vertices when removing the LODs! That’s weird because in the UE4 export settings, we can also uncheck “Level of Detail”, but in Blender the vertices are still messed up so that doesn’t work. But the way you do it works!
I noticed that the character is missing details, in your picture as well, and to fix that in Blender you have to uncheck Normals -> Autosmooth, or when you import you have to uncheck “Custom Normals”.

But I wonder how you got the shapekeys, I am not getting neither shapekeys nor materials. I get an error in Blender when I import the FBX that is probably related, do you also get this error? (Check bottom right after import to see the error notification)

Other people also have this error when importing an FBX that is probably made in Maya.
If you don’t get this error, then maybe you’ve done something differently, this is all the steps I followed:

LODs:

Export:


Blender:

I found a solution! I fixed the FBX using this Autodesk tool: https://www.autodesk.com/developer-n…erter-archives
I downloaded this one: “FBX 2013.3 Converter for Windows 64-bit”
In the tool, add the FBX, keep everything default, and click on Convert
Import the new FBX to Blender and you should see the Shapekeys and materials now.

But I’m still wondering how come you got the Shapekeys working without doing this?
You did not get the same error I got when importing the FBX in Blender?
Did I do something wrong in UE4 in the steps I posted?

2 Likes

Hey, thanks for posting all the steps for adding detail, and the solution to the problem!

You’re right, I messed up and was confusing the Vertex Groups for shapekeys (forgot how many bones the face has!). I wasn’t getting shape keys either! And I think I got that error on import too but I’ve been conditioned to ignore them… guess I should’ve paid more attention!

The materials not showing is a strange thing with ticking or unticking the LOD box on export. I did many combos today, but the best way by far is Thanks to DenRunner for the info on SETTING LOD to 1 … (stops messed up verts)
And Thanks to fuscrambled https://www.autodesk.com/developer-n…erter-archives … (gives shape keys)

download “FBX 2013.3 Converter for Windows 64-bit”

just open the exporter click ADD pick your file and press CONVERT in the bottom corner
this places a new folder with the converted file, your original stays where it is. (I did have a go at doing this without setting the LOD to 1 it still comes in messed up…) set the LOD to 1 in LOD SETTINGS before export in UE4… I imported the new FBX and all is good material slots - without textures so you will also need to download the textures and set up the nodes in each material you don’t need to set materials to each part that is already done.

you don’t need the converter for the material slots that is just down to the lod box being checked or not and other checkboxes can also mess this up

all the shape keys come in no problem using the converter it is a instant conversion it takes longer to find the file.

there are tons of shape keys and face bones I think its going to be a big job to link them all as I think they are to be used as bone smoothing…and there is no sign of the test animation??? going to try to get that in too, to save loads of work…

I have a 3d printer so I used an Xbox 360 Kinect to scan my full body and dragged out a make human model to fit the scan printed a face mask the nose and mouth were around 3mm off so corrected this. now I have a perfect fitting face mask drill out (or print with holes) to place face markers exactly every time I need face animations the holes are where the face bones are… going to use a couple of SQ12 mini cameras to make a rig £11 each then use blender face tracking to animate more than 2 cams should give 3d face tracking instead of the 2d from 1 cam… not all of us have IPHONES and don’t really want one just to do a face track.

using blender 2.90.0

2 Likes

@**DenRunner**Thank you for the LODs solution, I really thought it was not related to that because unchecking Level of Detail on export does not work. I’ll report this as a “bug”.

@getyamamout
**

**
That’s weird, for me the materials don’t import unless I repair the FBX with the tool. Without repairing, I only get the Vertex Groups. I use Blender 2.91

I did not know about this mask with holes technique. I’m making a characer creator for my game, and I never intended to do face Mocap, I was going to sculpt facial expressions manually. But then when I saw metahuman, I realised that it would be much better to use their system. I still don’t know yet if re exporting to UE4 after modifying the model would not break everything, and if we also need to move the face bones when we modify the mesh. If you want to make the system work in Blender, maybe there’s a way to write a script that connects the bones to the shapekeys.

Very welcome!

So, I was able to import it back into Unreal with all the morph targets and bones successfully, but when I hooked up the supplied LODSettings file and applied, the LODs it created didn’t actually have any reduced triangles (1-8 were all the same as LOD 0). I had to get rid of the LODSettings file to create the properly reduced LODs (but that limited the number of LODs to 6). There’s probably some settings we can tweak inside the file.

One thing I also noticed is that I lost the face post process animbp association (which contains the control rig), so that I couldn’t run live link to animate the face anymore. I’m sure there’s a way to reassociate the post process with the imported face, I just haven’t figured it out yet (might be possible to simply override the existing metahuman face by reimporting over it, and then we probably wouldn’t have to worry about losing the post process association).

I wanted to just ask in case I am going crazy - but none of the head blendshapes seem to do anything, right? It seems all of the facial stuff is bone-driven.
If I examine the head mesh in UE4 and, say, filter to “Cheek”, adjusting the blendshape sliders of these Cheek morphs never moves the mesh expression at all. But yet it has them.
I guess ARKit speaks its motion-info to the bones and not to the blendshapes?

Hi guys the bones seem to be the main driver and the key shapes are like a smoothing technique… have you ever seen how on an elbo or knee how the skin flattens out like a balloon? would people use key shapes along side the rig to stop this unnatural behavior and no Daffrendo your not mad as far as I know the movements are subtle some are more obvious than others… as to binding these key shapes to bones there are many youtube videos how to do this in blender

Blender 2.82 : Everything About Shape-Keys (In 2 Minutes!!!) - YouTube

I am moving bones around in pose mode to fit my existing model as close as I can before I even think about sculpting. I will bake the final pose as rest pose before doing any edit to the mesh this should prevent any weird movements and also prevent the textures looking weird. the nose eyes and mouth need extra care the corner of the nose around the side bulges is a very easy place to get stretching of textures. pop in and out of the texture view to see that all the skin looks right use the normals to check stuff like the frown likes are sitting right and the crows feet etc there should be 3 movement sets and the plain face

extra note when moving the face bones !!! they are not all semetrical and you may want to find the root to each bone group use front and side view to align these then hide them so you know there done then start aligning the group bones in pairs the rig is set for the character and for more realisum been slightly deformed you can do this as a finishing step but there are a ton of bones not a quick job matching and aligning them at the start will make it more easy

sculpting without placing the bones first will move the weighted area away from the designed movement area may cause problems

Materials… FBX export I have set to fbx2013 two boxed below in that section unchecked… the rest all ticked the material slots show in blender 2.90.0

the root groups move the root to area first then adjust the bones in that group then a final edit or sculpt can be performed without messing any animations up

I follow the solution and open the fbx in maya, but I found that the blendshape rig of in fbx file seems to be same with each other. why does this happen ?

With the bones being so obtrusive, it really does mean that it will not be able to be animated outside of UE4. Which means that all you can do outside of UE4 is (a) render, or (b) alter the mesh shape outside of Meta Human Creator. Does anyone think they can beat the render power of UE. And so with that, what’s left is the idea that Meta Human Creator will not be giving you the shaping features that you will ultimately want. I think that really the latter may wind up being the whole point of this - to shape beyond that which Meta Human Creator will likely itself allow.
Well, then credit here to all - returning back to UE4 with all functioning parts is an achievement!

I want to get the facial blendshape rig from the fbx file, then I can use this as a reference template to create more character rig. but when I download the fbx file and open it in maya following the solution above (which changes the number of LOD to 1), I found all the blendshape rigs in the fbx file to be identical with each other. I feel confused about this result, why does this happen ?

Did you try running the FBX converter that tofuscrambled mentioned?

“FBX 2013.3 Converter for Windows 64-bit”

Yes, but the converter seems to be no use. I can open the fbx file and there is 333 blendshape in the fbx file as shown above in the photo, but the blendshapes (skeleton mesh) in fbx file are all identical, can anyone give a explanation ?

Looking for your help !